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Welcome! 

 

Thank you for choosing Gradience TimeClock! This application replaces mechanical time 
clocks, eliminating hand correcting and tallying of timecards, and dramatically reducing payroll 
preparation time. 
   
 Gradience TimeClock features include:  

• Easy clocking in/out using keyboard, swipe card and fingerprint reader. 
• TC Remote software provides access to remote terminals swipe and punch entries. 
• Detailed time and date stamping of all entries, including employee and supervisor 

changes. 
• Instant knowledge of employee status through a virtual in/out board. 
• Fully customizable work schedules, rounding rules, overtime settings and more. 
• Data export function to major payroll provider software. 
• Direct transfer of timecard runs into employee time sheets in QuickBooks® Pro and 

Premier Editions 2003 and higher. 

• Flexible security access for employee and managers alike. 
• Integration with other Gradience programs simplifies data entry. 

When combined with Gradience Attendance, this powerful tool provides a comprehensive time 
and attendance tracking system for your business. 
  



Gradience TimeClock — New Features 

Gradience TimeClock has many new features designed to improve your productivity and improve 
timekeeping. We've added the following features to help you become more efficient, and hope 
TimeClock will help streamline your timekeeping operations! 
 
New features in TimeClock include: 

Features Shared with other Gradience Titles:  

• Redesign of Automatic Update Feature to improve its performance. (Can get updates 
through an automatic process or download update to a shared file before deploying – great 
option for IT departments.)  

• Improved installation process with database connection test to check id the database is 
connected correctly.  

• Improved usability for reporting features – moved checkboxes to be shown only when 
running reports.  

• Removed Edit mode from Guest Users, Global Preferences and Locations and 
Departments  

• Reduced save times  
• Added ability to sort by EmployeeID on Custom Reports.  
• Added ability to create Locations and Departments from the Employee Detail screen.  
• Moved Checklist from under View menu to Help menu. 

Gradience Time Clock Professional and Enterprise: 

• Intranet based web client for clock in/out – added browser based Time Station that allows 
remote clock in/out from a PC with Internet connection (Requires IIS to be installed).  

• Improved usability for work schedule input screens  
• Added feature to prevent double punching  
• Terminated and Inactive employees are now added to a TimeCard Run if they have paid 

hours during that date range.  

**Note: Updates versus Upgrades — Updates (also called minor updates) are new releases 
where the first version number has not changed. For example, if you purchase a Gradience 
product with version 10.x.x., you can update to any other version 10.x.x free of charge. Upgrades 
(also called major upgrades) are indicated by a change in the first version number. For example, 
when Gradience improves to the next higher first version number (from 10.x.x to 11.x.x), this is 
called a major upgrade. Major upgrades usually have a significant amount of new features and 
software improvements which warrant an additional charge. Upgrades require an upgrade fee. 
When Gradience performs an AutoUpdate, the fixes applied are minor updates, and are available 
free of charge. Contact Gradience sales for more information on how to purchase major 
upgrades.  



Unlocking the Demo       

You can unlock your demo copy after a new installation, or after you already have installed the 
program.   
  

New Installation 
  

You can unlock your installation immediately, or run any Gradience application in Demo mode. 
Here’s how: 

• During the installation of any Gradience application, you will be prompted to enter your 
license key in the Product Key window. 

• Enter the key in the Key field, or click Next to continue installing the application to run 
Gradience in Demo mode. 

• After running the applications in Demo mode, you will be reminded periodically of the 
Demo trial period remaining and have the option to purchase Gradience Attendance, 
Records or TimeClock. 

Previous Installation   

If you already have installed the demo of TimeClock, you can unlock it in one of two ways: 

1. Open Gradience TimeClock and click Enter Product Code to enter the product key. 
2. When the Enter Product Key window opens, enter your product key. It is not case-

sensitive. 
3. Click OK. A pop-up will indicate whether the key is valid or not. 

or 

1. Open Gradience TimeClock and click Continue in Demo Mode, enter the login and 
password. 

2. From within the program, click Help. On the drop-down menu, click Alter Current Product 
License. 

3. When the pop-up window opens, click on Edit Key. 
4. When the Enter Product Key window opens, enter your product key. It is not case-

sensitive. 
5. Click OK. A pop-up will indicate whether the key is valid or not. 

Note: There is a different product key for each Gradience product. 
  



System Requirements  

 

• Windows XP Professional (SP2), Windows 2000 Professional, Windows 2003 Server or 
Windows Vista 

• Pentium IV or Higher Processor 

• 512 MB available RAM (Random Access Memory) 

• 60 MB available hard disk space CD-ROM drive 

• SVGA monitor with 1024 x 768, High Color or higher 

•  Windows-compatible, graphics-quality printer 



Network Requirements       

• Windows-based Server or PC –  The included database is not compatible with a non-
Windows-based operating system, such as Novell. However, you may run the database on 
a Windows-based server or PC connected to a non-Windows based network.  

• A static (persistent) IP address so the database will always be connected to the client 
application. 

• Proper user license – The database will only allow the purchased number of users to be 
connected at any one time to the database. Wide-Area Networks (WAN) require an 
Enterprise license. The Product Key is affixed to the inside cover of the QuickStart Guide. 

• CD-ROM drive or access to our software download area on www.gradiencesupport.com.  

Citrix and Terminal Services: 
 

   

Although some of our customers have reported running the Gradience with Citrix we have not 
tested our software in such an environment. Also, the Gradience technical assistance is only for 
the applications themselves and not for troubleshooting network issues. We therefore cannot 
offer help with installation on your Citrix network. We also cannot guarantee that standard 
approaches to issue resolution offered by our Technical Support team will work in this 
environment.  
  

You may use the link below to access a PDF that may help.  
  

Citrix support 
  

Below is the only information that we can offer regarding Terminal Services.  
  

Standard Client/Server install on a Terminal Server  
Install the gradience product on the Terminal Services Server using the Add/Remove programs in 
the Control Panel.  
  
 On the Server where gradience is installed, go to Start, Run and enter: hrware.ini. This will 
bring up Notepad with the following info:  
[HRWARE]  

Server=Localhost  

Path=C:\Program Files\GNeil Software\Data\HRWare.gdb  

  

Change the Server information from:  
SERVER=LOCALHOST to SERVER=127.0.0.1. 

Even though Localhost is the same as the IP Address of 127.0.0.1, we have found that in many 
cases you will need to enter the IP Address instead of the name.  
  

We also found that the User would need to be logged on to the Terminal Service with 
Administrative rights. Without administrative rights, our database engine (Firebird 1.5) will not 
function, and the user will not be able to access the database file.  
  
This suggests that an Admin user has privileges to system files/DLL’s that a standard user would 
not. 
  

We welcome your sharing with us any insights that you gain from deploying our software on Citrix  



License Options        

Gradience products have similar licensing schemes. The options currently available are:  

• Professional  – Up to five users can run the program at the same time when connected to 
a single, common database. 

• Enterprise – Site License – Any number of users can run the program at the same time 
when connected to a single, common database from a single site (location).  

• Wide-Area Network (WAN) – licenses for multiple locations are also available. Please call 
for more information. 

   



Installing from the CD Menu        

To begin installing Gradience, follow these steps: 
1. Close ALL running programs.  
2. Insert the Gradience CD-ROM into the appropriate drive of your computer.  
3. The menu will appear. Select which product you want to install. (If the installation menu 

does not appear, click Start, Run. The Run dialog will appear. In the dialog box, type 
D:\setup.exe where D: is the letter of your CD-ROM drive. Click OK or press Enter. ) 

4. Once the installation procedure begins, follow the on-screen instructions to install the 
software. See Setup Types below for more information. It is recommended that you 
accept the default setting for each step of the install process. If you are installing the 
software in a network environment (Client-Server Installation), you should consult your 
network administrator before installation. You must have proper network rights in Windows 
2000 and XP to install Gradience software. 

5. When installation is complete, the Gradience program group will be added to your Start 
menu, and a Gradience TimeClock icon will be on your desktop. 

   



Setup Types       

• STANDALONE: Use this option if you are installing to a standalone computer. This will 
install the application files (TimeClock Admin and TimeStation) and database files to your 
local drive.  

• SERVER: This is the first of two steps in the Client-Server Installation, either for true client-
server configurations or a peer-to-peer network that may be using a workstation PC for the 
database. Choose this option to install the database and application files (TimeClock 
Admin and TimeStation) on the Server and before installing the Client application to PC 
workstations. 

• CLIENT: This is the second step in the Client-Server installation. This will install the 
application files (TimeClock Admin and TimeStation) and ask for the Server Name and 
Database Path. 

   

After clicking on a Setup Type, you will have the following options: 

• EXPRESS: We recommended that you select this option if you are installing or upgrading 
Gradience for the first time. This will take you through the installation process with 
minimum user intervention.  

• CUSTOM: This option is for Advanced Users who have specific installation needs, such as 
installing just the Time Station program on a client.  

   
NOTE: A Client-Server Installation is recommended. The database is more secure than if you 
install it on a Standalone computer, especially when installing Gradience TimeClock. When 
running Gradience TimeClock on a Standalone computer, you run the risk of someone changing 
the clock settings and creating false timecard entries. With a Client-Server Installation, the 
database and time are pulled from the server, not from the client workstation. 



Installing Gradience TimeClock 

This section explains how to install Gradience TimeClock to a Network or Standalone computer, 
and answers frequently asked questions about installing.  
   

Gradience TimeClock can be installed on a single standalone workstation or a network for 
database sharing among several users, depending on your needs.  
   

Regardless of which license you purchased, you may install the database to a network folder for 
the purpose of backup. Please consult your network administrator before installing to a network 
folder.  
   



Network Installation – (Client-Server)       

Installing a Client-Server setup is a two-step process. You will need to install to the Server first 
and then to the Workstation(s).  
   

To install to a network requires these items: 

• Windows-Based Server PC – The included database is not compatible with a non-
Windows-based operating system, such as Novell. However, you may run the database on 
a Windows-based server or PC connected to a non-Windows-based network.  

• A static (persistent) IP address so the database will always be connected to the client 
application. 

• Proper user license – The database will allow only the purchased number of users to be 
connected at any one time to the database. Wide-Area Networks (WAN) require an 
Enterprise license. The Product Key is affixed to the inside cover of the CD sleeve. 

• CD-ROM drive or access to our software product download area on 
www.gradiencesupport.com. 

   
NOTE: Gradience cannot provide technical assistance with setting up or maintaining your 
computer network. Please consult your computer manufacturer or network administrator before 
contacting Gradience Tech Support. 
   



Installing Gradience 

1. You may install from a CD or from a download. 

• From a CD:  
Insert the gradience CD, select Install gradience software and double-click on the program 
to be installed.  

• From a Download: 
After following the instructions on downloading Gradience to your desktop, double-click on 
the file to install.  
 
Note: To download, go to www.gradiencesupport.com, click on Download latest 
versions. Select the program that you need, click Download and then click Save. When 
the Save as window opens, put Desktop in the Save in field and then, click Save. 

2. You may install as a Server, a Client or a Stand Alone. 

• Server Installation: 
If installing several gradience programs on your network, only one program needs to be 
installed at the server.  
 
When prompted for the type of installation select Sever. When prompted for Custom or 
Express we recommend Express. If you select Custom you will be given the chance to 
“deselect” certain components. We recommend that you leave all components checked. 
The next prompt will allow you indicate where you want the database to reside. Please 
indicate a folder on physical drive rather than on the drive directly. An example of a custom 
path would be… 
 
j:\gradience\hrware.gdb  
 
Continue to follow the prompts. You will see a screen that shows where the database is 
located. Jot this location down or print this screen as prompted. You will use it at the client 
to verify that it is “pointed” properly to the database.  

• Client Installation: 
DO NOT map a drive from the client to the server. Our software uses TCP/IP to connect to 
the database via port 3050. Also DO NOT use UNC (\\) in either the name of the server or 
the path to the database.  
 
When prompted for the type of installation select Client. When prompted for Custom or 
Express we recommend Express. This workstation will look across the network and “self-
point” to the data up on the server. A prompt will indicate where this client is “pointed”. 
The client MUST be pointed to the exact drive letter on the server where the database is 
located, not a mapped drive. Be sure that the path to the database does NOT have double 
back-slashes (UNC) in the path.  

• Stand Alone Installation: 
When prompted for the type of installation select Stand Alone. When prompted for 
Custom or Express we recommend Express. If you select Custom you will be given the 
chance to “deselect” certain components. We recommend that you leave all components 
checked. The next prompt will allow you indicate where you want the database to reside. 
The database must reside on a physical drive and in a folder on that drive rather than on 
the drive directly. An example of a custom path would be…  
 
j:\gradience\hrware.gdb  



Possible Launch Error:  
 If after installation, you attempt to open gradience software from a remote location you may 
encounter an error message. Some remote-access software cannot resolve Localhost or the 
“name” of the server that can be found in the hrware.ini file of the server, client or stand alone 
workstation respectively. 

Resolution: 

1. 1. Remote to the desktop of the PC where you are attempting to open the program. 
(Server, Client or Stand Alone PC)  

2. 2. Click on Start > Run and enter hrware.ini into the field and click OK.  
3. 3. Second line from the top, change the “Server Name” or “Localhost” to the IP Address of 

the computer where the database is located.  
4. 4. Save and close the NotePad. Re-launch the program. If this fails, “physically” go to that 

computer to launch it.  
 
 

  IMPORTANT NOTE FOR VERSION 6 AND EARLIER USERS 

Gradience does not share the same database with Version 6 or earlier. You will need the 
Gradience Version of each program to share the database among the three separate programs. 
For this reason, you also should upgrade each program to the Gradience Version at the same 
time as ; otherwise, you may create multiple non-synchronized databases. 



Quick Note About Peer-to-Peer Installations       

A peer-to-peer connection allows you to share information between two computers without the 
need of a formal client-server connection. The peer-to-peer connection must be in place 
before following these instructions. See your Network Administrator for more details on setting 
up such a connection.  
   

On the host computer (the one on which you wish the database to reside), follow the instructions 
for a Server installation. Write down the Server Name and Database Path when prompted.   

Note: The Server installation will install both the software application and database files to the 
host computer. Then install the application as a Client on the other computer that will be sharing 
the information, entering the Server Name and Database Path when prompted. 

   



Upgrading from Optima or MyBiz to Gradience 

Version 7 and early editions of Version 8 utilized InterBase 6 open edition as a database engine. 
Nearly all PCs now come with hyper threading as a standard feature. Because of this, we no 
longer employ InterBase 6 because it doesn't work well in a multi-processor or a hyper-threaded 
environment. 
  

We now use Firebird 1.5 as our database engine. It works with multi-processor environments and 
we know of no issues with any brand of hyper threading available. When upgrading to Gradience, 
Firebird will NOT automatically replace InterBase. You will have to uninstall InterBase first as well 
as deleting the gds32.dll file. Then, install Gradience so that Firebird will install as your database 
engine. 
  

If you're upgrading from Optima or MyBiz to Gradience follow these steps: 
1. Back up your current data first. 
2. From your Control Panel click Add/Remove Programs. Look for InterBase 6 and uninstall 

it if you are not using it for another application. If you do not have InterBase 6, you may 
already have Firebird. If so, disregard Steps 3 and 4 below. 

3. After uninstalling InterBase 6 close out of Add/Remove Programs and return to the 
desktop. 

4. Do a search of your C: drive for gds32.dll. If you have this file, delete it. 
5. Now install Gradience. No data needs to be imported. Gradience will read the database 

you already have and upgrade it to a Gradience database. 
  
Note: DO NOT continue to use Optima or MyBiz. These programs will still be able to access the 
data. Using the older version to access the Gradience database may result in a loss of data. 
   

Updating from versions older than Version 6 

  
IMPORTANT! If you have been using Version 6 or below of Attendance Controller first make sure 
that your Benefit Labels are as follows: 
Vacation 

Sick 

Personal 

  

If your Benefit Labels are different, the database will not convert properly for Gradience to read it. 
  

The database in Version 6 and below is dramatically different from what has been used since 
Version 7. If you're upgrading from a version below 6, you will need to upgrade to Version 6 first 
and then to Gradience 2007 (Version 9). Version 6 is on the Gradience CD under the 
BIN/Legacy folder. For assistance, please contact Tech Support at 888-925-7740 or go to 
www.gradiencesupport.com and click on Ask a Question. 
  

Updating from Version 6 

  
IMPORTANT! If you have been using Version 6 or below of Attendance Controller first make sure 
that your Benefit Labels are as follows: 
Vacation 

Sick 

Personal 

  

If your Benefit Labels are different, that database will not convert properly for Gradience to read it. 



  

To upgrade from Version 6, follow these steps: 
1. Install Gradience 2007 (Version 9). For assistance, call Tech Support at 888-925-7740 or 

go to www.gradiencesupport.com and click Ask a Question. 
2. From the desktop click on Programs (or All Programs) > Gradience > Maintenance 

> DB Monitor. 
3. Login with ADMIN, ADMIN 
4. After the DB Monitor opens, click File and Exit and then, click Yes to shut it down. 
5. Now, install Gradience 2008 (Version 10). 



Auto Update Notification for Gradience TimeClock 
(Pro/Enterprise) 

Periodically, FREE updates may become available for this version of Gradience TimeClock.  
 

 

 When opening the program; if an update is available, the pop-up shown above will appear.  

Accepting the update: 

1. Click See what’s new to be directed to the Web page that contains the download link for 
the program that you need to update.  

2. When the pop up window opens; click Save. If you click Run the software will not install.  
3. A Save as window will open. In the Save in field enter Desktop and click Save to 

download the update.  
 

 



 
 

4. Once the download is complete; an installation icon like the one shown here will appear on 
your desktop.  

 
timeclock.exe 

Installing the update:  

1. Double click the installation icon to begin installing the update. You may also refer to the 
section on installation in the Help file within your program for more details.  
 
• Server Installation: 
Install the update on the server or on a workstation that is “behaving” as a server for our 
program first before installing the update on individual “client” workstations. Ensure that 
your current version is not open. Double-click on the downloaded installation icon. When a 
prompt gives a choice between Server, Client and Standalone, select Server. When a 
prompt gives a choice between Custom and Express, select Express. This is true even is 
you had done a Custom installation originally. This is because you already have an 
established ini file [hrware.ini] that will properly direct the program to the data.  
 
• Client Installation: 
Now move the installation icon to the desktop of a client. When a prompt gives a choice 
between Server, Client and Standalone, select Client. When a prompt gives a choice 
between Custom and Express, select Express. Repeat at any additional client 
workstations running this software.  
 
• Stand Alone Installation: 
If you only have the program on one computer and the data is also on that same computer, 
double-click on the downloaded installation icon. When a prompt gives a choice between 
Server, Client and Standalone, select Standalone. When a prompt gives a choice 
between Custom and Express, select Express.  
 

2. When the installation is complete, click the original program icon to open the program.  
3. From within the program, click Help > About to view the updated, multi digit version 

number.  
4. Make a record of this full, multi digit version number. When contacting Tech Support, 

indicate this number.  

Choosing not to update at this time:  

1. Click Remind me later.  

Note: At any time while using the software, you may click on Help at the top. From the drop-down 
menu click Check for Updates. If one is available you will see the pop-up shown here.  
 



 
 

 If no update is available, the pop-up shown below will appear.  
 

 



Configuring and Using Time Station 

At this point, you already should have installed Time Station. If you have not yet done so, you can 
learn how to install Time Station here.   

Configuring Time Station is a three-step process that includes Configuring and Connecting 
Time Station, Reconfiguring Time Station, Configuring Time Station for use with 
TimeClock. 

  

Configuring and Connecting Time Station 

Follow the steps below to complete the initial Time Station configuration: 

1. Before you do anything else, make sure you have installed and launched TimeClock.  
2. Once you have verified that TimeClock is running and you have clicked Launch Time 

Station on the last window of the Time Station installer, you will see the initial configuration 
window 

3. Type in the IP Address of the TimeClock computer (click here to learn how to find it).
1
 

4. If you do not know or cannot find the IP Address of the TimeClock computer, then you 
need to know the network name (Computer Name) of the TimeClock computer. You can 
find all the computers on your network by clicking Browse. Time Station will return a list of 
computers on your network. Note that not all of the computers in the list will be running 
TimeClock, so make sure you have found the name of the TimeClock machine first so you 
can recognize it when the list appears. 

5. Once you have completed either the IP Address or Computer Name field, click Save. 
 
If you have successfully connected to the TimeClock computer, you will see the following 
message: 
"IP Address and Computer Name updated successfully" 
 
 

6. After the correct information is received and any issues are resolved, the Time Station 
employee login window will appear and the setup is complete.  
 
Note: the Status field appears inside the left side of the interface when Time Station has 
connected successfully with TimeClock. The two status indicators are Connected or 
Disconnected.    

                                                 
1
 You need to have the IP Address of the computer running TimeClock in order to correctly  configure 

Time Station. You can find this information by navigating to  TimeClock | Preferences tab | Time Station 

Configuration container.   Look for the field labeled TimeClock IP Address.  Write down or memorize the 

address. 



Installing Time Station 

Time Station is free software that, when installed and connected properly to TimeClock, runs on a 
remote machine in your office and allows employees to clock in and out. Before you can use 
Time Station, you will need to install it on a remote computer, which typically is NOT the same 
computer as the one running TimeClock. 

 Follow these steps to install Time Station: 

1. Make sure you have TimeClock installed first. Then, navigate to the 
TimeClock|Preferences tab and find the field in the Time Station Configuration window 
labeled TimeClock IP Address. Memorize or copy this number down - you will need it 
later when you learn how to configure Time Station. 

2. Go to the computer onto which you want to install Time Station. Using the CD or the 
download setup package, double-click Setup to run the installer. 

3. Install Time Station, taking all the default prompts. You will need to accept the Gradience 
License Agreement to install and use the application. 

4. You will be given the option to test your connection to the database. Enter your server 
information and click "Test Connection." 

5. Once you are finished , there is a Launch Time Station check box. Put a check in the box, 
then click Finish. 

6. The Time Station installation is complete. Visit the topics below to configure Time Station 
to work with TimeClock. 

  

Why should I avoid running Time Station on the same computer as TimeClock?  

As an HR Administrator or support person, you are probably busy using your machine for other 
purposes. Employees need to clock in and clock out at various times of the day, Time Station 
keeps this activity from disrupting your daily work flow by allowing them to use another computer 
connected via your network to your machine (the TimeClock machine). Additionally, because 
Time Station has remote capabilities such as the Change Employee Password feature, it's easy 
to make those adjustments at the remote machine, just as you could at your TimeClock 
computer. This flexibility lets you perform this and other procedures remotely should the need 
arise. If, however, you need to test your connectivity with Time Station and your magnetic swipe 
reader and cards, you can follow the Technical Note below to set up your TimeClock machine to 
perform some tests. 

Technical Note 

Want to connect TimeClock to your Time Station on the same machine for testing purposes? Just 
put 127.0.0.1. inside the IP Address field on the first Time Station configuration screen. You now 
are connected to your own machine with minimal configuration. Next you can use TimeClock and 
your USB (or serial) card reader to swipe magnetic stripe card data into your ID Card Number 
fields for each of your employees.  

 Once finished with this process, you now can test your TimeClock /Time Station connectivity and 
features by starting Time Station and swiping a magnetic stripe card through the reader. 

  

  



Intranet Installation 

Follow these steps to install the intranet function on Time Station on your system. 

Windows Vista Install:  

1. Install the TimeClock application  
2. Install IIS  
3. Go to Start>Control Panel> Program Feature> Turn Windows features on/off 

Check/Select IIS>Web management tool>IIS management compatibility>Check all 
options underneath>select -World Wide Web services>Application Development 
Features> .Net extensibility>asp.net 

4. Restart Computer  
5. Install the Web Time Station file by using the Set up file. When prompted during installation 

browse to the Program Files area to identify where the database was installed. Copy and 
paste the path into the field. The next install screen is the site configuration screen local 
host will be populated by default in the site field and Time Station will be populated by 
default on the virtual directory  

6. Upon completing the installation open a web browser and enter: 
http://localhost/timestation 
If the time station graphic is displayed the installation was a success.  
 
Note: When it is first initiated on a machine it will take a few seconds to connect after that 
initial connection delay, no further delays are experienced.  

XP Install 

Follow these steps before installing: 

1. Install IIS  
2. Then install .Net 2.0 framework  
3. Install the TimeClock application and then install the Web Time Station feature  

 
Note: If .Net is installed before IIS go to Add/remove programs and select change/remove 
the .Net 2.0 framework. Select "Repair." This should fix the way you see the data in the 
browser.  

Across the network   

1. Install the Web Time Station file on another computer and during the configuration screen 
enter in the name or IP address of the computer that TimeClock or Time Station is installed 
on  

2. Site name and virtual directory should stay the same  



Troubleshooting Time Station 

The connection is established between TimeClock and Time Station when Time Station "finds" 
the TimeClock computer on the network. Some common reasons the Time Station might not be 
able to connect include the following: 

1. UAC or Security Access issues with Windows Vista (we recommend clicking Allow for 
TimeClock/TimeStation if prompted to resolve this issue). 

2. Windows Firewall with Windows XP SP2 (we recommend clicking Allow or setting the IP 
address or name of the Time Station machine to pass through the firewall). 

3. Other popular firewall applications (such as Zone Alarm) or packet sifting and filtering 
applications might also prevent connectivity, so check those and allow both machines 
connectivity through the LAN before attempting to reconnect. 

4. Under some circumstances, you might see the error message below: 
"Unable to find Gradience web service on the IP Address 192.168.1.139. Please select a 
different IP Address." 
 
This error message can appear when one of several problems has occurred: 
 
•  Ensure TimeClock is running (remember, Time Station is trying to establish a connection 
via your local network with TimeClock).  
•  Check the IP Address of the TimeClock machine and make sure it is correct.  
•  Check the Computer Name and verify the name is correct.  
•  Ensure your machine is configured with the same IP Address range and subnet as the 
TimeClock computer.  
•  Make sure you have network connectivity (can you browse for and see other machines 
on your network?).  
 
If these troubleshooting steps fail, please contact Gradience Technical Support. 



Auto Update 

Single PC without IT support  

•••• PC needs Internet and FTP access 

•••• User must have PC and Network Administration privileges to complete these tasks. 

Turn on Auto-Update (Client PC)  

1. From within any Gradience application  
2. Go To Settings > Global Preferences > General Settings – Select “Enable Auto 

Update”  
3. From Help Menu – Select “Check for Updates”  

Multiple PCs without IT support  

• User must have PC and Network Administration privileges to complete these tasks.  

Option A 

1. Follow the same steps as used for a single PC environment. 

Option B 

• Gradience Version 10.0.712.13 or higher  
• One of the PCs must have Internet and FTP access  
• Must set up Network Shared Folder for GNSiteMirror application to write to it and for 

other PCs to read from it. The GNSiteMirror application replicates the FTP Update site to a 
local PC or Server.  

 Install GNSiteMirror application   

• See below. 

PC with IT support  

• An IT Administrator must perform these tasks 

Option A   

1. Follow the same steps as used for a single PC environment. 

Option B 

• Gradience Version 10.0.712.13 or higher  
• One of the PCs must have Internet and FTP access  
• Must set up Network Shared Folder for GNSiteMirror application to write to it and for 

other PCs to read from it. The GNSiteMirror application replicates the FTP Update site to a 
local PC or Server.  



Install GNSiteMirror application  

• See below. 

Turn on Auto-Update (Client PC)   

1. From within any Gradience application  
2. Go To Settings > Global Preferences > General Settings “Enable Auto Update”  
3. From Help Menu – Select “Check for Updates”  

Turn Off Auto-Update (Client PC)  

1. From within any Gradience application  
2. Go To Settings > Global Preferences > General Settings – Deselect “Enable Auto 

Update”  
3. Use the management tool of your preference to perform the software installation.  

GNSiteMirror Installation: 

1. Installing the gnsitemirror.msi download application 
- Installing from Gradience CD:  
Navigate to the Gradience CD > BIN > Gradience > Site Mirror folder and double click on the 
Gradience Site Mirror.msi file.  
- If you don’t have a Gradience CD, you can download the file from our Website at: 
http://downloads.gneiltechsupport.com/downloads/Gradience Site Mirror.msi  
After downloading, double-click on the file to start the installation process.  

2. Point the gnsitemirror application to a shared folder 

a. Start the gnsitemirror application. You can find the shortcut at Start > Programs > 
Gradience > Gradience Site Mirror. This will place an icon in the System Tray (near the 
clock in the bottom right).  

b. Right-click on Gradience Site Mirror select Settings.  
c. In the Select Download Folder box, enter the shared path down to the folder where you 

want the clients to pull the updates from. The path will be created if it doesn’t already exist. 
This folder will need to be shared so others can map to it.  

d. Select the options:  
Days between updates (minimum of 7 days) – this is how often this computer will check 
for updates from the FTP site.  
Update Time (computer must be turned on to check updates) – this is when you want this 
computer to check for updates.  
Start Gradience Site Mirror each time Windows starts – (Recommended) – allows the 
program to start automatically each time the computer is restarted.  

e. Click OK.  
f. Right-click on the icon in the System Tray and select Update Now. This will download any 

available updates for the current version.  

3. Set the Auto Update Settings for each Client Computer 

a. From each client computer, open the Gradience program.  
b. Go to Settings > Global Preferences > General Settings Tab and enable the option for 

Automatic Updates. Close out of the Global Preferences.  
c. Go to Help > Auto Updater Settings and set the path to the shared folder.  



Before You Begin 

You should have the following information available: 
1. Location and Department names 
2. User Information (managers, supervisors, administrative assistants and others who will 

have access to the data) 
3. Employee Data (Employee Name, Hire Date, Work Status (full- or part-time), Active Status 

(Active, Inactive or Terminated), Location and Department, Day Work Hours and Week 
Hours). You will need additional information about employee schedules, overtime and 
rounding rules, payroll categories and codes, etc., to fully set up Gradience TimeClock. 



Navigating the Management Windows 

Gradience TimeClock is now easier to navigate than ever before. The main parts of the 
Gradience user interface are the Menu Bar, Program Bar, Feature Column, Employee Select 
Column, Selected Feature Pane and the Recent Features Pane. 



Menu Bar 

The menu bar includes the following options: 
Menu Description 
  
File  

Maintenance - Backup Database – Backs up the Gradience database. 
Export TimeClock Data –   

Import Data – Imports basic data into the database. 
Export Data – Exports basic data from the database. 

Delete – Deletes current employee record. 
Exit – Closes program. 

 [Employee Name(s)] – The last seven employees who have been entered or edited will show here for quick 
navigation back to their record. 

   
View  

Filter Page – This option allows you to filter by Active, Inactive, Terminated, Full- and Part-Time Status. 

Open Reminders – Shows open reminders that have not been resolved and whose date has not passed.  

Checklist – Shows the Checklist for getting started.  
Welcome – Shows the Welcome Screen.  

   
Settings  
   
   
   

User Security – This screen allows you to set up user access. 

Global Preferences – This feature allows you to set up settings that affect features within the program.  
Guest Users – This option is for users who want to set up access to the database using a third party tool, such as 
Crystal Reports.  
Reason Codes – This allows you to set specific reasons when entering paid time for an employee.  
Locations and Departments – This feature allows you to create your locations and departments. 

Messages – These messages will be seen when employees clock in and out.  
Work Schedules – This allows you to set rounding rules (grace period) for employees clocking in/out.  
Time Difference – If you have multiple sites in different time zones, this option will allow you to set the difference in 
time for each computer connected to the database. 

Reports There are 12 different reports from basic employee information to viewing timecards and tracking deleted time clock 
entries (see Using Reports). You also may customize a report to fit most needs through Custom Reports. 

 
Menu Description 
  
Help  

Contents – This brings up the Help File for Gradience TimeClock. Note: Internet Explorer 4.x and above needs to be 
installed for this option to work. 
System Information – This gives you information about your computer, database path, and other information that is 
needed when speaking to our Technical Support team. 
About – This shows the version number, type of license (Single-User, five-user, 10-user or Unlimited), and User Login 
Name. A link to the Tech Support site is also here. 
Alter Current Product License – This allows you to enter a new Product Key Code.  

   



Feature Column 

The Feature Column includes the following options:  
Employee Detail allows you to add new employees and edit employee information. This screen is shared between 
Gradience Attendance, Confidential Employee Record and TimeClock.  
In/Out Board allows you to view the clock in/out status of employees at a glance.  
Reminders allow you to view, edit and create reminders. 
TimeClock Access allows you to set up employee access to clock in/out. You may give employee access to create, 
edit and/or delete their own time entries. 
TimeClock Entries allow you to maintain employee time entries. You may view, add, delete and edit time entries as 
needed.  
Time Card Runs allow you to view, print or export timecards  
   



Toolbar 

The Toolbar contains buttons that allow navigation between feature records and allows editing of 
employee information.   

 
   



Starting Gradience TimeClock       

Gradience TimeClock consists of two applications: the main application - Gradience TimeClock 
Admin – where administrative work is done, such as setting up logins, editing timecards and 
printing timecard runs; and a separate application called the Gradience TimeStation, where your 
employees clock in and out. 

To start the TimeStation, click Start > Programs > Gradience > TimeStation or double-click 
the program icon on the computer where your employees will clock in/out. 
   

The TimeStation is where your employees will clock in and out. Employees may clock in and out 
using the keyboard or swipe card with magnetic stripe reader or TC Remote Terminal. 



Opening the Management Screen       

The Management Screen allows you to view and edit employee time entries, run reports and set 
program options. If you have the Gradience TimeClock (full program) installed on the same 
computer where user can clock in/out, you will have the option to log into the management screen 
by clicking Management > Management Login. Or you may get to it by clicking Start > 
Programs > Gradience > TimeClock.  
   
NOTE: A Management (Administrator) Login is different from an Employee Login. A Management 
Login allows access to set up screens, timecard entries and reports; Employee Login only allows 
employees to clock in/out and manage their individual time entries. 
   



Logging into the Management Screen 

A user login is different from an employee login. An employee login (set under TimeClock 
Acess) will only have access to the My TimeClock feature and to clock in and out. A user login 
(set under User Security) will allow managers, supervisors, and other administrators access to set 
up and maintain Gradience TimeClock.  
   



Login and Password 

If you’re logging in for the first time, the default user login is Admin, and the default password is  
Admin. For security purposes, we highly recommend changing this password after you log into 
the Management screen.  
   



Gradience TimeClock Checklist        

For first-time users, the Gradience TimeClock Checklist will appear. If you do not want this 
window to appear at startup, click I am finished with the checklist. To show this window from 
within Gradience TimeClock, choose View > Checklist.  
   

The Checklist shows in order the sections you should complete to get up and running quickly.  
   

• Change the Admin password by going to Settings > User Security. We highly recommend 
changing the Admin password even if there aren’t other users. If needed, set up access for 
others who will need to help you set up the program. If you need to give access to specific 
locations and departments, or individual employees, set these up first and then come back 
to User Security and complete security access. (See Setting Security Rights.) 

• Create Locations and Departments (Creating Locations & Departments.)  
• Set up Global Preferences. (Setting Up Global Preferences .) 
• Set up preferences (Setting Up TimeClock Preferences.) 
• Set up Reason Codes (Setting Up Reason Codes.) 
• Create Work Schedules (Creating and Editing Work Schedules.) 
• Add Employees (Adding a New Employee.) 
• Assign TimeClock Access (Assigning TimeClock Access.) 
• (Optional) Setting Up Gradience for Time Zone Differences (Dealing with Time Zone 

Differences) 



Changing the Admin Password       

Option One: Setup rights from scratch.  

Option Two: Duplicate the rights of another user.  

  

See Note at the bottom of these instructions.  
  

Option One: Setup rights from scratch. 
1. From any screen, click Settings > User Security.  
2. Click the New and enter new log-in and Full Name.  
3. Enter new Password and enter password again in the Verify Password field.  

 
Feature Access- By default, the Detail button (not Employee Detail) will be depressed. A 
feature list associated with the Detail button will appear at the lower right,  

1. Click on each item in the Access Rights column one at a time. When you do, the item will 
highlight and a down arrow will appear. Click on the down arrow and a drop-down menu 
will appear.  

2. Click on the selection that provides the appropriate level of access. Repeat this for each 
item on the list of features. You will have an additional button on your screen for each 
Gradience program installed:  

•••• Gradience Attendance  

•••• Gradience Records  

•••• Gradience TimeClock  

•••• Gradience COBRA  
Click each of these buttons respectively and repeat steps 1, 2 & 3 directly above. This will inform 
the database as to the level of access this person will have for each program loaded. Do this only 
once.  
  
Now click the Location/Department button and ensure that the appropriate Locations and 
Departments are checked. If you wish to have access to selected features for all locations and 
departments, you will need to check them all.  
  

Option Two: Duplicate the rights of another user.  
1. Click Settings > User Security and highlight the user who’s rights are to be duplicated. 

To have your “new” administrative password “automatically” have the same, full rights as 
the default administrator login; highlight ADMIN on the list on the left. See first “Note” at 
the bottom of these instructions.  

2. Click the double-green checkmarks (Save as) button at the top. A pop-up window will 
open.  

3. Enter the new login, enter the name of the new user, enter the new password and enter 
the password again.  

4. Click Save.  
  

Notes:  
1. To deactivate ADMIN, Click on ADMIN on the list on the left and then, under Is User 

Active, click No.  
2. To “nearly” duplicate another user’s rights, follow the steps in Option Two but before 

saving, “change” the access rights to those features that need to be restricted or 
enhanced. Then, click Save.  

   

   



Creating Locations and Departments       

Locations and Departments are required and must be assigned to each of your Employees (See 
Adding New Employees to assign Location/Department to employees). 
   
Note: When setting up Locations and Departments for the first time, a Location must be set up 
first, and then you may assign a Department to that Location.   



Setting up Locations and Departments 

Setting up Locations and Departments is a critical task and must be performed before you can proceed with 

other data entry steps. During the process, you will create Locations first, and then Departments afterward. 

Departments then can be assigned to Locations. Follow these steps: 

1. Click on Settings > Locations/Departments.  
2. With Locations already selected, click New, enter the name of the new location and click 

Save. All of the departments that have been created thus far will be made available to the 
new location. Simply check those departments that are appropriate to the new location and 
leave unchecked any departments that do not apply to the new location.  

3. To create a new department, click Departments and then click New.  
4. Enter the name of the new department and click Save. It will be available to all locations. 

Assign as needed by checking the new department for each location for which it is valid. 
Leave it unchecked for those locations for which it is not valid.  
 
Note: After creating new Locations or Departments, you need to refresh the Employee 
Detain screen for them to be available. To do so, look to the upper right. Just under the 
Gradience logo click the black X in the white box.  

NOTE: As you add more locations and departments, you will see that each location has ALL of 
the departments you have created. However, only those departments you assign to a location will 
show up when assigning them on other screens. You may not remove a Department from a 
Location if an Employee is still assigned to that Location/Department combination. After adding 
and editing locations and departments, they may not immediately be available on the drop-down 
menu on the Employee Detail Screen. While on the Employee Detail Screen, click the "X" below 
the Gradience logo in the upper-right corner. Then, return to the Employee Detail Screen and the 
new location/department should be available.   



Setting up Global Preferences        

Global Preferences allow you to control your default program settings, such as Company Info, 
Report Options and specific program options.  
  

See below for detailed information on each tab. 



Company Info Tab  

The Company Information screen allows you to enter your company name, address and logo. We 
recommend entering the company name and logo because these will print out on Reports.  
Feature Description 
Company 
Name 

(Recommended) This will display on the report heading.  

Address, 
City, 
State, ZIP 
and 
County 

(Optional)  

Remove 
Current 
Logo 

This allows you to unselect the current logo. 

Assign 
New Logo 

This allows you to select a new logo. This logo will display on the top left of reports. 

Save 
Logo to 
disk 

This allows you to save the current logo to disk or to your hard drive.  

   



Editing Company Info 

Follow these instructions to edit the company info: 
1. Click Settings, Global Preferences. Enter information as needed. 
2. Click Save.  

   



Adding a Company Logo 

If you have your company logo available in a bitmap (. bmp) or jpeg (.jpg) file format, you can 
have this logo appear on reports. Gradience supports .bmp and .jpg file formats not to exceed 
200 x 200 pixels in size. The logo will appear in the top left when you print a report. 
   

To add a company logo, follow these steps: 
1. Click Assign New Logo.  
2. Navigate to the directory where the company logo is stored. It can be in a .bmp or .jpg 

format no bigger than 200 x 200 pixels in size.  
3. Click on the logo and then click on Open to select it.  
4. Click the Save button.  

   



Saving Logo to Disk 

You may save the logo to a directory on a disk or hard drive. When you add a logo within 
Gradience, the logo is actually saved within the database file.  
   



General Settings Tab 

The General Settings screen allows you to enter the default hours in a day that employees will be 
assigned, and allows use of the Forgotten Password Utility. This screen also allows settings for 
Forced Writes to Firebird and prompting to backup on exit.  
   

Feature  Description 
Epoch 
Setting 

We strongly recommend keeping the default settings. This setting will allow the Gradience program 
to appropriately interpret any two-digit year entered that is between 1920 and 2019. For example, 
with the default Epoch setting of 1920: 

• If you enter a date (such as in the Hire Date field) of 03/05/01, the program will interpret this as 
03/05/2001. 

Note: If you need to enter a year before 1920 or after 2019 in a date field within the program, you 
may enter the year as a four-digit number.  

Default 
Hours in 
a Day 

These are the default hours that will be assigned when creating a new employee. The Day Hours on 
the Employee Detail screen will be filled in automatically with these default hours when a new 
employee is created.  

National 
ID 
Number 
Format 
/Label 

Selecting one of these options will allow you to set the mask for the National ID Number Format. The 
default mask is set to the USA SSN format. With this selected, whenever you enter a new employee, 
the dashes automatically will come up in the xxx-xx-xxxx format. The label is the title that will appear 
on the Employee Detail screen. 

   

Feature Description 
Allow use 
of 
Forgotten 
Password 
Utility 

This option allows access to a utility that can be used, only with assistance from Tech Support, to 
gain access into the Gradience program. Call Tech Support if you have forgotten or lost your 
Gradience password. 

   
Forced 
Writes for 
Interbase 

•  If running the Gradience database on a Standalone computer, this option will help to keep the 
database more stable. A Workstation is more prone to lock up or crash than a Server. If the 
Gradience database is installed on a Workstation and the program is open at the time the 
computer locks up or crashes, the database is prone to becoming corrupt and possibly 
irreparable. A computer lockup or crash can be attributed to several things, including having 
too many programs open at the same time than what your computer memory can handle.  

• If the database is installed on a Workstation or Standalone computer, we recommend keeping 
this option checked. The performance may lag a little, but unless you have more than 800 
employees, you may not even notice it. We also recommend having a current backup, created 
within Gradience or DB Monitor, available. If the database is installed on a Server, normally a 
backup of the whole Server is created on a daily or regular basis. We still recommend setting 
up Scheduled backups within DB Monitor, but having this option checked is not as important 
on a Server. 

  

Prompt 
for 
backup on 
Exit  

This option allows you to turn on or off the message prompting for backup when you close out of the 
program. Backups are very important. We recommend that you turn this feature off only if you have 
scheduled backups within the DB Monitor.  



Report Options Tab 

The Report Options settings affect how reports will appear by default.  
Feature Description 
Print 
Preview  

Toggles (turns on and off) showing preview first before printing 

Header 
Bold  

Toggles bolding for Header Title 

Header 
Line  

Toggles putting a line under the Header Title 

Header 
Shade  

Toggles shading for Location or Department title row 

Data 
Line 

Toggles lines to separate data information 

Print 
SSN 

Toggles ability to show Social Security Numbers  

Print 
Picture  

Toggles ability to print Picture on printout 

Print 
Totals  

Toggles whether Totals show up on reports 

   



Editing Report Options 

To Edit Report Options, follow these steps: 
1. Choose an option by clicking in the box.  
2. ClickSave.  

   



Attendance Tab 

The Attendance Tab will show only if Attendance is installed. 
   



Setting Up TimeClock Preferences        

The TimeClock Tab allows you to set global settings for Gradience TimeClock. This also will allow 
you to enable Attendance and TimeClock code sharing.  
Feature Description 
Time Format This allows you to set the time to display in military style or 12-hour style.  
In/Out Board 
Settings  

a.   Enabled– This allows the user to view the In/Out Board from the main screen. 
b.   Display Time – This will show the clock in/out time for the employee. 

c.   Require Login – This causes the In/Out Board to require a login and password. 
Time Display 
Rate 

This causes the main clock to be viewed in seconds or minutes. 

Attendance 
Code 
Sharing  
(See Setting 
Up 
Attendance 
Code Sharing 
for detailed 
information.) 
   
   

If you have Gradience Attendance installed, the following options will be available:  
a.   Enable Code Sharing - This will allow hours worked and paid time off codes to be shared 

between Gradience Attendance and TimeClock. For example, if a code “V” for Paid Vacation of 
eight hours is entered on the Calendar in Gradience Attendance, this time also will be entered 
into Gradience TimeClock as a manual time entry of eight hours.  

Feature Description 
Attendance 
Code 
Sharing 
(Cont.) 

b.   Enable Hours Worked Transactions Relation - (Enable Code Sharing must be checked for 
this option to be available.) This allows the “W” code (Hours Worked) entry in Gradience 
Attendance to be entered as a manual time entry in Gradience TimeClock.  

b.   Reported Payroll Description Columns - Reason Code = Payroll Code Description = Related 
Attendance Absence Code.  

Note: Reason Codes and Payroll Code Descriptions must be set up before assigning the Reported 
Payroll Description Columns. (See Setting Up Reason Codes.) 

Sync with 
the server 
every 120 
second(s) 

This is how often the client will synchronize the main clock with the server.  

User must 
login/punch 
within 30 
second(s)  

Once a user enters the first character into the login screen, a countdown timer starts. If a user 
doesn’t finish entering his or her login and password within the allotted time, the screen will reset the 
main clock screen.  

Enable 
Swipe Card 
Usage 

This allows you to enable the use of swipe cards. (Swipe cards and swipe card reader required.) 

Require 
Password 
when 
Swiping 

Users will be required to enter a password when swiping in. 

Enable “Auto 
Clocking” 

This enables the “smart” clocking feature. When users clock in the first time, the program clocks 
them in. The next time the user will be clocked out and so on. If 13 or more hours pass between 
punches, this feature will be reset and will take the next punch as an In punch.  

Require 
Password for 
manual 
Employee 
Login 

Users will be required to enter a password when clocking in/out.  



Require 
Password for 
access to My 
TimeClock 

Users will be required to enter a password when going into the My TimeClock feature.  

Request 
confirmation 
if user is 
double 
clocking 

Double clocking is defined as two In punches or two Out punches in a row. If a user tries to clock 
in/out twice in a row (within a 13-hour period), a message box will pop up asking for confirmation. 



Setting up Reason Codes        

You may get to Reason codes by going to Settings > Reason Codes. 
   

When you make a change to a punch entry, you are required to enter a reason for the change. All 
changes, such as deleting or editing a punch entry, are tracked and recorded. Reason Codes 
allow you to create these reasons customized for your company. There are different kinds of 
reasons:  
Feature Description 
Use for Punch Changes Reasons you would use when making a change to a punch. For example, you might enter a punch 

time for an employee because he or she forgot to punch in. (The reason would be Forgot to Punch.) 
Use For Deleted Entries Reasons you would use when deleting a punch or time entry. For example, you would delete a 

punch or time entry because someone punched in twice. (The reason would be User Error.) 
Use For Time Entries (Manual Time 
Entries) 

Reasons you would use when entering a manual time entry. For example, you may want to enter 8 
hours of Paid Vacation for an employee. (The reason would be Paid Vacation.) This reason is also 
associated to Gradience Attendance, if code sharing is checked. 

   

Typical reason codes could be Forgot a Punch, User Error or Computer Down. For example, if 
the new employee, Josh, came in at 8:30 AM and forgot to clock in, Josh’s supervisor would 
need to create a punch entry for 8:30 AM so Josh gets credit for that time.  
Feature  Description 

Reason Code This is the name of the reason (PTO, Sick, Personal, User Error, etc). 
Enabled When checked, this allows the reason code to show up when editing time on the TimeClock Entries 

screen. 
Use for Punch Changes These are Reason Codes you want to see when you're doing a manual punch (Clock In or Out) 

change. A punch change changes or adds a specific punch in/out time entry. This is different from 
giving a full or partial day (see Use for Time Entries below). 

Use for Deleted Changes Whenever you delete an entry, you'll need to enter a reason. These are the Reason Codes that you 
want to show up when DELETING an entry. 

Use for Time Entries These are reasons you only want to see when entering a manual time entry, suc
Personal, Sick, etc. A manual time entry is normally entered to give a full or partial day. For example, 
you might enter four or eight hours of time for an employee that is on Vacation. This reason is 
different from giving a single entry for punching in or out for a specific time (see 
Changes above).  

Count Towards Overtime 
Calculations 

When checked, this setting tells TimeClock to count time under this Reason Code towards overtime. 

Payroll Code Description (Optional) Enter a Payroll Code Description. This description will show up on the Time Card Runs 
report. If a Payroll Code Description is not entered, time will be shown in the “
reports. 

Payroll Code Number (Optional) Enter your company’s Payroll Code Number. This payroll code number will show up when 
exporting time card runs. 

Related Attendance Absence Code -
This option will only be available if the 
Enable Code Sharing is checked (under 
Global Preferences > TimeClock 
Tab).  

This allows an Absence Code from Gradience Attendance to be directly related to a Reason Code in 
Gradience TimeClock. When an absence or time worked code is entered on the Attendance 
Calendar, this entry will be entered in TimeClock according to the related Reason Code. Similarly, 
when you create a manual entry with a Reason Code in TimeClock, an Absence Code appears on 
the Attendance calendar screen. 

   



Creating a New Reason Code 

To create a new reason, follow these steps:  
1. Go to Settings > Reason Codes. 
2. Click New. 
3. Enter a reason for the following: 

1. Reasons you would use when making a change to a punch.  
2. Reasons you would use when deleting a punch or time entry.  
3. Reasons you would use when entering a manual time entry.  

NOTE: You can select multiple uses for a reason code. For example, when using 
the reason code “Off Site,” you may want to be able to select this when entering a 
punch change or when entering a full or partial amount of time. 

4. Select Enabled. This will allow the reason to be selected when making changes. 
5. Click Save.  



Work Schedules       

You may get to Work Schedules by going to Settings > Work Schedules. 
   

There are some things in life that nobody has control over that may make an employee late for 
work. Many companies give a grace period to employees when punching in or out to cover these 
occasional events. Setting up a Work Schedule allows you to give a grace period from 2 to 60 
minutes. You may run an Exceptions report to show if employees are abusing this right.  
   

Schedule is not set up or assigned; employees will be clocked in/out with no rounding or overtime 
rules. You will also not be able to run the Punch Exceptions Report.  
   

Under Work Schedules, you also may set up overtime and punch schedules and rules that 
govern how to handle shifts that go past midnight into another day. You will need to set up your 
rounding rule (Work Schedule) and assign that rule to each employee. The most common 
rounding rules of 6, 10 and 15 minutes already have been set up for you.  
   

To set up your rounding rules, go to the Settings menu, then Work Schedules. (See Create and 
Edit Work Schedules for detailed instructions on setting up Work Schedules.) 
   

To assign a Work Schedule to an employee, go to the TimeClock Access Feature, then Current 
Work Schedule. (See Assigning TimeClock Access.) 
   



Printing Work Schedules 

You may print all current Work Schedules by going to Settings > Work Schedules and clicking 
on the Printer icon.  
   



Printing Employee Assigned Worked Schedules 

To print the work schedules that are assigned to employees, go to Reports > Work Schedule 
Assignments. 
   



Adding Employees       

You may get to the Employee Detail Feature by selecting Employee Detail under the Feature 
Column. 
   

All employees are entered through the Employee Detail screen. From here, you can enter their 
names, Social Security Numbers (optional), Hire Dates, Job Titles, and other pertinent 
information. This information is shared among Gradience Attendance, Records and TimeClock. 
This means that when you enter this information in one program, you’ll be able to see it in the 
other Gradience programs. 
   



Required Fields 

The following fields are required: First Name, Last Name, Hire Date, Work Status, 
Employment Status, Location, Department and Day Hours. SSN is not required in Gradience, 
but may be required when exporting Timecard Runs for certain payroll programs. 
   

To add a new employee, click New. (See Required Fields.) Click Save after entering employee 
information.  
  

Note: Locations and departments must be set up before entering new employees. (See 
Locations/Departments to set these up.) 
   



Assigning TimeClock Access       

To allow employees to clock in and out, Enable Employee TimeClock Access will need to be 
checked under TimeClock Access. You also may give employees access to create, edit and/or 
delete their own time entries.  
   

To assign access to an employee, follow these steps: 
1. Select the employee you want to allow to clock in/out by clicking on his or her name in the 

browse window.  
2. Select the TimeClock Access button. 
3. Enter a login name. The employee will use this to log in to clock in/out and to gain access 

to the My TimeClock feature. My TimeClock allows employees to see their time entries.  
4. Enter a password, and enter it again in the Verify Password block.  

See Also:  
 Giving Employees Access (Managing Employee Records) 
Setting up Employee Access (Fingerprint Setup) 
   



Creating TimeClock Messages       

To get to the TimeClock Messages screen, go to Settings > Messages. 
   

This screen allows you to enter messages employees will see when they clock in or out. You may 
even set how long the message will stay on the screen.  
   

To display a message, type your message in the message block for either Clock In or Clock Out 
Message, then click Save.  

   

Note:The Clock In message will display whenever an employee clocks in, and the Clock 
Out message will display whenever an employee clocks out. For example, when an 
employee clocks in to begin the workday, the Clock In message will display. This same 
message will display when the employee clocks back in from lunch.  

   



Reminders 
   

The Reminders feature will show you all open (unresolved) reminders and allow you to create, 
delete and resolve reminders. If you have created a reminder, it will show up when you first open 
the program, starting on the reminder date. Reminders will continue to display until you click 
Resolved.  
   

Reminders Tool Bar and Pane Layout 
       

Tool Bar: 
First — Prior — Next — Last arrows – Navigates through selected reminders 

New – Creates a new reminder 
Edit – Allows you to make changes to a reminder 

Save – Saves reminder 
Cancel – Cancels current changes 

Delete – Deletes selected reminder 
Print – Lets you print the Reminders report for selected employees 
Help – Brings up help for this screen 

   

Pane Layout: 
Reminder Date – Date reminder should first display 
Title – Heading of reminder 

Resolved – Checkbox displays checked for resolved or unchecked for open (unresolved) 
Employee Name – Displays name of employee that reminder is associated with 

User – Displays name of user that reminder will display for 
Description – The purpose of the reminder shows here 

   

Filters: 
User – Allows you to view reminders associated with specific users (must have access to 
Reminders, Assign Users under User Security) 
Show Resolved – Displays Resolved reminders only 

Show Unresolved – Displays Unresolved (open) reminders only 
   

Creating a New Reminder 
   

There are two types of reminders in Gradience:  

• One Time Reminders – These are reminders that are meant only to remind you of a one-
time event, such as: 
• Filing an Absence Report at the end of the year.  

• Recurring Reminders – These remind you of the following recurring events:  
• Anniversaries (Gradience Attendance) 
• Birthdays, Performance Reviews, and I-9 Renewals (available if Gradience Records is 
also installed) 

   

Setting a Reminder 
   

One-Time Reminder: 
1. Click on Reminders from the Features Column.  
2. Click New.  
3. Select (check) One-Time Reminder.  
4. Enter a Title and Reminder Date 



5. If you want the reminder to be associated with specific employees, select the checkbox, 
“Assign to all selected (checked) employees.” This is optional and will create a separate 
reminder that is associated with each employee.  

6. If you selected the checkbox in Step 5, you will need to select (check) any employees this 
reminder is about in the Employee Select Column. Otherwise, skip to the next step.  

7. By default, the User’s name will default to the login that was used to enter the program. 
Change this if you want the reminder to come up for another user, or you may select 
Global, which allows the reminder to come up for all users logging in.  
Note: You must have access to Reminders, Assign Users and Reminders, Assign Global 
under User Security to be able to change this option.  

8. Enter a description of the reminder, if needed. 
9. Click Save. 

Recurring Reminder 
1. To create a recurring reminder, follow these steps: 
2. Select Reminders from the feature list. 
3. Click New. 
4. Select (check) Recurring Reminder. 
5. Select the type of reminder: Anniversary, Birthday, Performance Review or I-9 

Renewal. 
6. Select a Through Date (when do you want to stop the reminder from occurring). 
7. Select how many days you want to be reminded before the event. 
8. By default, the User’s name will default to the login that was used to enter the program. 

Change this if you want the reminder to come up for another user, or you may select 
Global, which allows the reminder to come up for all users logging in.  
Note: You must have access to Reminders, Assign Users and Reminders, Assign Global 
under User Security to be able to change this option. 

9. Enter a description of the reminder, if needed. 
10. Click Save. 

Deleting Reminders 
   

Reminders are deleted from the Main Reminders screen by clicking on the Delete icon.  
   

Editing Reminders 
   

There are two ways to edit reminders:  
1. Main Reminders screen - From the main Reminders screen, you can edit the following 

columns just by clicking in the field: Reminder Date, Title, Resolved and Description. 
2. Edit Reminders screen - Clicking on Edit from the main Reminders screen will bring up 

the Edit Reminder screen. You also may double-click on the title of a reminder. The Edit 
Reminders screen allows you to change the Title, Reminder Date, User and Description. 

Note: If you need to change the Employee Name this reminder is about, you’ll need to delete 

the reminder and then recreate it.  

   

Open Reminders 
   

Open reminders will appear for the user they are assigned unless the Global option is checked. If 
a reminder is marked with Global, then it will show for all users. You may view open reminders by 
opening the program or selecting Reminders from the feature list.  
   
Note: If you have security access to “Reminders, Assign Users” (see User Security), you may 
view reminders set up by other users. You also may resolve reminders from the Open Reminders 
screen.  



   

   
   
   
   

   
   
   



Dealing with Time Zone Differences       

If you have departments in different time zones that are connected to the same Gradience 
database, you can set up Gradience to account for the time differences. Without this feature, all 
punch times, whether in different time zones or not, will have the time of the Server where the 
database resides.  
   

An example of using Time Difference: If the main server is in Florida, and someone clocks in from 
Utah (two hours behind), the punch time would be recorded at Utah’s time, as it should.  
   

To get to Time Difference, go to Settings > Time Difference. 
   

To set up computer time differences, follow these steps: 
1. Have each computer open Gradience TimeClock (and then exit) at least once before 

continuing. Each computer should be connected to the same database. They do not have 
to sign into the Manager’s Section; just open Gradience TimeClock to the first screen with 
the clock.  

2. Setting the time difference should be done from the main server where the database 
resides. From Settings > Time Difference, you should see the name of each computer.  

3. Enter a Difference Reason for each computer. The reason could be the department name, 
state, or anything else to remind you where that computer is. Computer names will not 
always be descriptive. 

4. Enter the time difference. Enter time zones behind you with a number to include the minus 
sign.  

5. Click Save. 



Any punches from the different time zones will be clocked in at their respective times.  



Setting up Attendance Code Sharing       

Gradience Attendance and TimeClock can be fully integrated. This means that absence codes 
(paid time off), such as Vacation that is entered into one program, will also be entered into the 
other automatically 
  
Example: Linda takes a vacation day; her supervisor enters this time into TimeClock so that she 
is paid for the day. With integration set up, this time will also show on the calendar in Attendance 
as a "V" — Paid Vacation Day  

  

Steps to follow: 
1. Click Settings > Global Preferences > TimeClock Tab. 
2. Under Attendance Code Sharing on the TimeClock tab, click Enable Code Sharing. 

 



  

Note: 
If you wish, you may also select Enable Hours Worked Transactions Relation if you are going 
to enter Hours Worked (W Code) on the calendar in Attendance. With this option selected, when 
a "W" is entered on the calendar, it will also be entered into TimeClock automatically. 
  
You set the default hours in a normal workday in Global Preferences. 

  
In the event that a "W" needs to have a value associated with it that is less than or greater than 
the default hours in a normal workday, you would need to: 

1. Right-click that particular "W" and select Absence Detail. 
2. Enter the amount of hours that should be associated with that "W" and then click Save. 



Set up Reason Codes  

(See Setting Up Reasons Codes for detailed information) 
After turning on the Attendance Code Sharing, the next step is to set up Reason Codes. You may 
already have Reason Codes set up; if so, go to the next step of setting up payroll code 
descriptions. Reason Codes allow you to select specific reasons when entering a manual time 
entry. Some examples of Reason Codes are: Vacation, Sick, Personal, Computer Down, 
Corrected Time Entry, etc.  
   

Example: Linda takes a vacation day, when the supervisor enters a manual entry in TimeClock to 
record the time off, the time is entered as eight hours and the reason code is Vacation.  

Feature Description 

Reason Codes Reason Codes are required reasons when changing a punch entry or entering a manual entry.  
Payroll Codes Payroll Codes are descriptions that will show on reports and are related to Reason Codes and 

Absence Codes. 
Related 
Attendance 
Absence Codes 

Related Absence Codes will allow absences that are entered on the Calendar screen to also be 
reported in TimeClock.  

   
   

To set up Reason Codes, go to Settings > Reason Codes. 
   

Whether correcting an entry or entering time for someone out on vacation, entering a manual 
punch requires a reason. The three types of reasons are: Punch Changes (making a change to a 
punch time entry), Manual time entries (entering a time entry for eight hours Vacation, etc.), and 
Deleted time entries.  
   
The Reason Code window can be broken down into three parts: Reason Code, Payroll Code 
Description, and Related Attendance Absence Code.  
   
   
   



Set up Payroll Code Descriptions and Numbers 

(See Set Up Payroll Code Descriptions for detailed information.) 
A Payroll Code Description is related to a Reason Code and Absence Code. The Payroll Code is 
the description that will show up on reports (such as the Timecard Runs report).  
   
Example: A Reason Code of Vacation is set up. When someone takes a vacation day, a manual 
entry (from the TimeClock Entries screen) is created and given the Reason of Vacation. A 
Payroll Code Description of Paid Vacation is set up relating it to the Reason Code (Vacation). 
When a timecard report is run, it will show the Payroll Code Description of Paid Vacation (the 
Payroll Code is what will appear on reports). When that manual entry with the Vacation Reason 
Code is created, it also will create an entry on the Calendar in Gradience Attendance under the 
V- Paid Vacation absence code.  
   



Set up Payroll Description Columns for Reports 

When running a report, such as the Timecard Runs report, only two payroll descriptions will show, 
along with Regular Hours and Overtime hours, due to space constraints. If there are any other 
payroll code descriptions, they will show up in the Other Column. The Timecard Runs (Extended) 
report will show all payroll descriptions in a column format.  
   
After setting up the Payroll Code Descriptions, you’ll be able to set up which two payroll codes 
you’ll want to see, in addition to Regular Hours and Overtime Hours; time for all other payroll 
codes will be combined into the Other Column.  
   

To set up the two Payroll Description Columns, follow these steps: 
1. Go to Settings > Global Preferences > TimeClock Tab. Payroll Description Columns 

for Reports, locate First Column and Second Column. 
2. Click on the drop-down arrow for First Column and select which payroll code you’d like to 

show up on the Time Card Runs report.  
3. Then click on the drop-down arrow for Second Column and select another payroll code. 
4. Click Save. 

  
   



Set up Attendance Absence Codes 

Once the Attendance Integration is enabled, you’ll be able to relate Reason Codes in TimeClock 
to Absence Codes in Attendance. When you enter an Absence Code onto the Calendar that is 
related to a Reason Code, this will create an entry in TimeClock.  
   
Example: We have a Reason Code of Vacation = Payroll Code Description of Paid Vacation = 
Related Attendance Absence Code of V – Paid Vacation; when entering a V Code on the 
Calendar of eight hours, this time will automatically be entered in TimeClock as eight hours of 
Vacation (Reason Code). And this time will be shown on the Time Card Run report as eight 
hours of Paid Vacation(Payroll Code Description). 
   
   

With code sharing set up, this is how it will work: 
   
From the Calendar screen, we enter a V –  Paid Vacation day (Related Absence Code) on June 
5, 2007. 
   

From the TimeClock Entries screen, we can see it reports the time as Paid Vacation (Payroll 
Code Description).  
   

If we double-click on the Changed By Date at the bottom of the TimeClock Entries screen, we can 
see Vacation as the Reason for Change (Reason Code). 
   

It shows our columns of Paid Vacation (First Column) and Paid Personal (Second Column) with 
16 hours of Paid Vacation showing for Neil Adams.  
   

And it will work the opposite way; if we enter a manual entry in TimeClock, it will display in 
Attendance. 
   



Security Options 

Due to the confidential nature of information stored in TimeClock, security is always turned on. 
This will help prevent unauthorized persons from accessing critical employee data. The use of 
security is required, and setting up access to TimeClock and any other Gradience programs you 
have, should be the second thing you do. The first thing you should do (after changing the 
Administrator password) is set up Locations and Departments.To view the setup tasks you should 
perform, and the order in which they should be performed, click Help > Checklist from the main 
menu.  

You may set up access for managers to view only their departments and/or view specific 
employees from other departments. You may also set up employees to have read-only access to 
their records.  

Encrypt Data feature 

Gradience Attendance contains a Global Preference > General Settings button called Encrypt 

Data. By clicking Encrypt Data and entering the secret key of your choice, sensitive information 
such as Social Security Numbers can be encrypted in the HRWARE database. This feature can 
help prevent the casual viewing of Social Security numbers by unauthorized persons.  

To decrypt your data, simply navigate back to the General Settings and click Decrypt Data. Your 
data will no longer be encrypted.  



User Security - Detail Tab 

Features common to Gradience Records, Attendance, TimeClock and COBRA 

• Search For – This allows you to search by User Name.  
• Save As – This allows you to create additional users based on the access rights of another 

user.  
• Employee Record Access – This allows access to view, add or delete employee records.  
• Employee Detail – This grants access to the Employee Detail screen.  
• View SSN – This allows access to view Social Security Numbers.  
• Run Reports – This allows access to run reports.  
• Reminders – This allows access to add and delete reminders.  
• Reminders, Assign Global – This allows access to assign reminders as Global.  
• Reminders, Assign Users – This allows access to assign reminders to other users.  
• User Security – This allows access to add, edit, and delete users and user access.  
• Location/Department Maint – This allows access to assign location /department access 

for users.  
• Global Preferences – This allows access to edit global preferences.  
• Database Monitor – This allows access to the DB Monitor.  
• Database Backup – This allows access to Backup from the DB Monitor only.  
• Database Restore – This allows access to Restore from the DB Monitor. 
• Alter Product License – This allows access to enter a product key to change a license.   
• Product License. Conversion – This allows access to run the Conversion Utility.  
• Custom Reports – This allows access to create/modify Reports.  
• Import Data – This allows access to import employee data into the database.  
• Export Data – This allows access to export employee data.  
• Guest Users – This allows access to connect to the database via a third-party ODBC 

driver.  

Setting Access 

Setting up access to common features (Detail Tab).  

1. From the User Security screen, click Detail>New.  
2. Enter a Log In and Password (letters and numbers only) and the user’s Full Name.  
3. Select options for Displaying Reminder Alarms and Hints for this login.  
4. Select Yes to "Is User Active" to allow the user to begin logging in after giving access. 

Setting this option to No is a good security measure when users are out of the office for a 
number of days.  

5. Select what type of Feature Access users will have by clicking in the Access Rights field.  
6. Clicking on the arrow will allow you to select from the following:  

NO ACCESS – no access to selected feature  
READ ONLY – allows user to view only, cannot make any changes  
READ WRITE – allows user to view, add, and edit; no deleting allowed  
READ WRITE DELETE – allows user full editing rights to feature  
YES – allows access to feature  
NO – no access to feature  

7. Click Save.  

Program Specific Features: 

TimeClock 



• TimeClock Entries – This allows access to the TimeClock Entries screen.  
• TimeClock Access – This allows access to the TimeClock Access screen.  
• Work Schedules – This allows access to the Work Schedules screen. (See Setting up a 

Work Schedule.)  
• Time Card Runs – This allows access to the Time Card Runs screen.  
• TimeClock Settings – This allows access to the TimeClock Settings screen.  
• Messages – This allows access to the TimeClock Messages screen.  
• Time Codes – This allows access to the Time Codes screen.  
• In/Out Board – This allows access to the In/Out Board.  
• Export Data – This allows access to Export Data from the reports.  



User Security - Locations and Departments 

You should have already set up your Location and Department names (see Locations and 
Departments). Now you will want to set up users’ access to the Locations and Departments by 
following these steps:  

1. Click on Location/Department tab from Settings > User Security > Detail.  
2. Click on the “+” (plus sign) next to Locations/Departments and next to the location and 

department name to expand the list.  
3. Click in the check box next to the location and department name to select access to these 

areas or individual employees within these departments. This will put a checkmark in the 
box. Click in the box again to de-select (or clear) the item.  

4. If you have already entered your employees in the program and assigned location and 
departments to them, when you expand a department, you will see all the employees 
assigned to that location/department combination. You may then select access to 
individual employees at this point by clicking in the box next to the employee.  
 
Note: If you have not yet entered your employees (through the Employee Detail feature 
or Import Data under the File Menu) into the program, you will still be able to assign 
access to a location/department combination, just not down to the employee level. You 
may later assign access down to the employee level after you enter your employees and 
assign a location/department to them. 
 
 

5. Click Save.  



Clocking In/Out 

There are two ways to clock in and out of Gradience TimeClock, and both are described below. 
You can use a keyboard or a magnetic swipe card using a card reader. Gradience TimeClock 
may be installed on one or two central computers or on all of your employees’ computers so they 
may clock in/out from their desks.  
   
Note: Employees use the Gradience TimeStation to clock in/out. Managers and supervisors use 
the Gradience TimeClock Admin portion of the program to manage employee time.  
   

We have made clocking in/out as easy as possible. Employees clock in and out from the 
Gradience TimeStation application. Employees may clock in using the keyboard or using a 
magnetic stripe card (swipe card) and card reader.  
   

Using a swipe card and card reader allows for faster clocking in/out, but may not always be cost 
effective. You may install Gradience TimeStation on your employees' computers and allow them 
to clock in/out from their desks. (See the Software License Agreement at the front of the manual.) 



Clocking In Using the Keyboard       

Before being able to clock in and out, an employee must have TimeClock access. (See Assigning 
TimeClock Access.) To clock in using the keyboard, employees would enter their logins and 
passwords and click on Clock In (F5) or Clock Out (F8).  
   

Employees with time clock access also have access to the My TimeClock feature. My TimeClock 
allows employees to see their own timecards. If given the proper rights, employees may also 
create, edit and delete their own time entries within My TimeClock.  
   



Clocking In Using Swipe Card and Card Reader       

If you have a magnetic stripe card reader and cards, purchased separately, it will log employees 
in/out and allow them to get into My TimeClock without having to enter a login and password.  
 
As an added security feature, you may require that an employee enter a password, even while usi
ng a swipe card.  This may cut down on an employee's clocking in/out for another employee.  



Remote Terminals       

This section explains how our program works with remote terminals. A remote terminal is a data 
collection station that looks like a 10-key pad with a magnetic stripe card reader attached. The 
remote terminal is connected by a network cable that allows you to have a small data collection 
station in areas where you don’t want or need to have a full computer and monitor setup.  
   

A remote terminal collects the data (such as someone clocking in/out) and sends the information 
to the database where it processes the data through stored procedures. In other words, it does all 
the processing at the Server where the database resides. The remote terminal has a live 
connection to the Server, so if the Server goes down, employees will not be able to clock in or out 
until the Server connection is restored.  
   



Setting up a Remote Terminal       

To set up a remote terminal, you will need the following: 

• One or more TimeClock Remote hardware clocking stations  
• Gradience Remote Terminal Program 
• Gradience TimeClock Program 
• Static IP Address 

   

The Remote Terminal Program allows you to enter an IP Address of the Remote Terminal.  
   

You can set up the remote terminal anywhere you can set up a connection to the network.  
   

Setting the IP Address on a remote terminal 
1. Have your Network Administrator set up a static IP Address for each remote terminal you 

plan to implement. NOTE: Tech Support cannot assist in setting this up.  
2. Connect the Remote Terminal to your network through an Ethernet cable. 



TimeClock Ethernet Terminal 

TimeClock Ethernet Terminals are small, low-cost-data collection devices that communicate with 
Gradience TimeClock over a TCP/IP network. The network interface supports both 10BaseT and 
100BaseT Ethernet connections. The operator interface consists of an LCD display and 
membrane switch keypad with additional operator input options for barcode, mag-stripe, and 
auxiliary RS-232 serial port.  
   

Theory of Operation 

When the TimeClock Remote terminal is connected to an Ethernet network, it functions similarly 
to a “dumb” terminal. The host software can send commands and displayable messages to the 
terminal via the network. User input is entered at the keypad or mag-stripe reader and is sent to 
the host software. To minimize network traffic, the user input is transferred as complete strings 
instead of character by character. Strings are terminated by the “Enter” key and terminated with 
the ASCII <CR> & <LF> characters. The mag-stripe input automatically includes the “Enter” 
function. 
   

Terminal Emulation 

The ET214 terminal has two (2) emulation modes, the “Virtual Terminal Command” (VTC) mode 
and the “ANSI Emulation Mode." The VTC mode provides a unique but simple protocol that 
eliminates the need to know all the particulars of the lower-level ANSI protocol. The ANSI 
emulation mode is a subset of the standard ANSI terminal protocol that supports most of the 
standard display manipulation command set. For more information on these emulation modes, 
see the “Software Interface” section. 
   

Network Interface 

The TimeClock Remote terminal connects to a 10BaseT or 100BaseT hub via a standard RJ-45 
Ethernet cable. From a network perspective, it occupies a single “socket” at a specified TCP/IP 
address and port number. The device must be configured with a unique IP address, net mask and 
port number BEFORE it is installed on the network (see “Network Configuration Mode”). The host 
software communicates with the terminal by establishing a connection with the terminal and then 
sending and receiving ASCII text command strings. 
   

Operator Interface 

The TimeClock Remote includes an LCD display and a numeric keypad as the primary operator 
console interface. In addition, the terminal may include optional barcode and/or mag-stripe input 
readers and an auxiliary RS-232 serial port for connection of a serial input device. 
   

Display 

The TimeClock Remote display is a two (2) line by twenty-four (24) column LCD character 
display. It can display the 96 standard ASCII characters and 96 nonstandard symbols in a 5 x 7 
dot matrix font. The cursor position is identified by a blinking box and can be positioned under 
software control. A display back light is available as an option for low-light installations. 
   

Keypad 

The TimeClock Remote operator keyboard consists of a four (4) row by six (6) column membrane 
switch keypad. Two (2) shift keys (“S1” & “S2”) are provided to generate upper case alpha 
characters and several special characters. The keypad also includes “IN” and “OUT” keys for 
manually clocking in/out and “YES” and “NO” keys for answering program questions.  

   

Default Alpha/Numeric Mode 

   



   
The shift keys ("S1" &  "S2") are used to expand the number of ASCII characters that can be 
generated by the keypad. Holding down a shift key and pressing one of the other 22 keys 
generates an alternate ASCII character. For example, holding down  "S2" and pressing the  "7" 
key generates the ASCII "B" code. In addition, holding down both shift keys and pressing a 
function key results in a special local terminal function. The following table shows the assigned 
local terminal functions. 

Key 
Combination 

Local Function 

Pressing Bottom 
Row Character 

Enters the bottom character. For example, pressing “7” enters the number “7” on the keypad. 

S1 & [top left 
character] 

Enters the top left character. For example, pressing “S1” & “A” enters the letter “A” on the keypad.  

S2 & [top right 
character] 

Enters the top left character. For example, pressing “S2” & “B” enters the letter “B” on the keypad.  

S1 & S2 + IN Enter Network Configuration Mode 
S1 & S2 + OUT Enter Configuration Mode 
S1 & S2 + 
Cancel 

Reboot Terminal – Reboot requires reconnecting through the TC Remote program 

   



Setup and Configuration 

It is strongly recommended that you read these instructions on setting up and configuring the 
TimeClock Remote terminal BEFORE attempting to install it.  
   

The TimeClock Remote terminal must be configured for Gradience TimeClock BEFORE it can be 
installed and used on the network. Configuration parameters can be modified through the 
operator console and are saved in nonvolatile memory. Network communication parameters are 
entered with the “Network Configuration Mode” and the console parameters are modified with the 
“Console Configuration Mode.” 

   

Configuring the TimeClock Remote terminal is done in three steps: 
1.   Configuring the Network Configuration. 
2.   Configuring the Console Configuration. 

3.   Setting Up the TC Remote program. 
   

Network Configuration Mode 

The Network Configuration Mode is used to configure the TimeClock Remote communications 
parameters. These parameters must be set BEFORE the terminal is installed on the network. 
Holding down the “S1” & “S2” shift keys and pressing the “IN” key will start this mode. A menu 
will be displayed and pressing the “2” key will allow access to the network parameters. The 
display will present a series of configuration parameters and their current values. A value can be 
changed using the keypad and pressing the “Enter” key. After the last parameter is entered, the 
values are saved in memory and the menu is display again. Exit from the “Network Configuration 
Mode” is accomplished by pressing the “Enter” key at the menu.  
   
The following table summarizes the “Network Configuration Mode” parameters and the VTC 
command names used to change them. NOTE: Only the MYIP, NETMASK and MODE 
parameters need to be configured to work with Gradience TimeClock. 

Name Default 
Value 

Description 

MYIP 192.168.1
68.50 

Defines the unique network address of this terminal. This value must be set BEFORE installing the 
device on a network. The default value may NOT be appropriate, and a new address should be 
obtained from the network administrator. 

NETMASK 255.255.2
55.0 

Defines the network mask for the IP address. This value must be set BEFORE installing the device 
on a network. The default value may NOT be appropriate, and a new value should be 
obtained from the network administrator. 

 

Name Default 
Value 

Description 

GATEWAY 0.0.0.0 Can be set to the address of a router or gateway if the network extends to multiple segments. This 
value must be set BEFORE installing the device on a network. The default value may NOT be 
appropriate, and a new address should be obtained from the network administrator. 

TCPPORT 1070 Defines the primary TCP/IP port number used for this terminal. This value must be set BEFORE 
installing the device on a network. In most cases, the default value will be acceptable. However, it 
may NOT be appropriate, and a new port number should be obtained from the network administrator. 
It should be set to 23 for a “telnet terminal” application. 

SERVER 0.0.0.0 Defines a TCP/IP address for a server application. This value must be set BEFORE installing the 
device on a network. Normally, this value is set to 0.0.0.0 which causes the terminal operate as a 
“server” and connects with a host computer running a “client” application. If this value is set to any 
other IP address the terminal will operate as a “client” and will attempt to automatically connect to a 
host computer “server” application. 



AUXPORT 9600,0,8,1,1 Defines the communications format for the aux serial port. The parameter string consists of five (5) 
integer value fields and has the following format: 
Baud, parity, data bits, stop bits, xoff Where: 
Baud = standard baud rates in the range of 110 – 57600 

Parity = 0 (none), 1 (even), 2 (odd) 
Data bits = 7 or 8 

Stop bits = 1 or 2 
Xoff = xon/xoff protocol (0=disable, 1=enable) 

MODE 1 Defines terminal emulation mode. The two (2) valid emulation modes are as follows: 
1 = VTC Mode (default) 
2 = ANSI Mode (Gradience setting) 

MYMAC 0050C216300
7 

This command will return a 12-character hexadecimal string representing the Ethernet hardware 
address. It is read only and can not be used to change the hardware address. 



  



My TimeClock       

My TimeClock allows employees to view their timecard history, and, if given rights, can create, 
edit and delete their timecard entries. An employee can log into My TimeClock by clicking on the 
My TimeClock button, or pressing the F9 key). The password for My TimeClock is the same one 
used when clocking in/out. (SeeTimeClock Access for setting up employee’s login and 
password.)  
   
Tip: Employees may log into My TimeClock using their swipe cards at the My TimeClock login 
screen. 
   



Employee Review/Edit Toolbar 

If given the proper rights, an employee may have access to New, Edit and Delete. This will allow 
them to manage their own timecards. All changes and deletions are tracked, and managers may 
run reports against these changes.  
   

 
   



Creating a New Time Entry 

You must be given rights to this feature. Clicking New, from the TimeClock Entries screen, will 
give you the New Entry window with the following options:  
   

 
   
After clicking on New, you’ll be given the choice of Clock In / Clock Out or  Enter Hours.  
   
Selecting Clock In/Clock Out will allow you to enter a manual punch entry just as if an employee 
had clocked in or out. For example, you may enter a manual punch entry of 05:15 PM for a 
specific date.  
   

Feature Description 
Reason for 
Change 

A Reason is required for Creating a Manual TimeClock Entry or Entering Hours for a Date. 

Date This is the date of the punch entry. 
Punched This designates In or Out of the punch. 
Time This is the time of the punch entry. 
Work Date This is the Work Date the punch refers to. 
Comments Comments are not required but may be helpful when reading a reason at a later date. 
   
Selecting Enter Hours will allow you to give a set amount of hours for a given date. For example, 
you may enter a manual time entry of eight hours Vacation.  
Feature Description 
Reason for 
Change 

A Reason is required for Creating a Manual TimeClock Entry or Entering Hours for a Date. 

Feature Description 
Date This is the date the employee will get credit for.  
Work Date This is the Work Date that the punch refers to. 
Hours  This allows you to enter specific hours for a date, such as eight hours for a Vacation day. The Date, 

Hours and Reason for New Entry fields are required. 
Count 
toward 
overtime 
calculations 

Designates entry to count toward overtime. 

Comments Comments are not required but may be helpful when reading a reason at a later date. 
   



Date Versus Work Date 

When creating a new time entry, there are two date fields: Date and Work Date. The Work Date 
represents the date the entry is counted toward. Normally, you won’t need to change the Work 
Date unless you have work shifts that go past midnight. For example, Josh starts work and clocks 
in at 8 PM on Monday night. He gets off work at 4 AM on Tuesday morning but forgets to clock 
out. A manual time entry is created for him, punching him out at 4 AM; the Work Date is of the 
previous date (the actual date Josh started work). The program knew that Josh had clocked in at 
8 PM the previous day, and because he had not gone over 13 hours between punches, it counted 
the OUT punch to the previous date. 
   



Editing a Time Entry  

Edit allows you to change an existing entry. You must be given rights to have this feature. 
Remember that the Reason for Change block is required and tracked. Editing a time entry is 
similar to creating a new entry except you only have the choice to change a punch time entry. 
   



Deleting a Time Entry 

Delete will erase the selected time entry and record the deletion. All changes and deletions are 
recorded and tracked. To view deleted time entries, go to Reports > Deleted TimeClock Entries.  
   



Printing an Employee Timecard 

Print allows you to print an employee timecard for the selected date range.  
   



Getting Help 

Help allows you to bring up the help file for this screen. 
   



Timecard Entries 

The timecard entries have the following coding: 
Feature Description 
Blue 
band 

A blue band designates the selected entry. 

White 
band 

A white band designates an IN punch. 

Teal 
band 
(bluish 
green) 

A teal band designates an OUT punch. 

Gray 
band 

A gray band designates that a manual entry was given for a set amount of hours. For example, Josh 
took eight hours of Vacation on 3/15/2002, and a manual entry was entered for his time.  

Plus (+) 
Sign 

A plus (+) sign designates a punch was changed or manual entry was entered. 

Asterisk 
(*) 

An asterisk (*) designates that there is a double-punch; either two IN punches or two OUT punches 
together. Action should be taken on such an entry of either adding a new entry or correcting an 
existing entry. Hours cannot be calculated for a double-punch entry.  

   
CAUTION: If you see an asterisk (*) next to a time entry, this means that some action should be 
taken, such as correcting a punch.  
   
   
   
Tip: Right-clicking on an entry will show you the rounding rules (Work Schedule Rules) for that 
entry. 
   



Managing Employee Records 

This chapter will help you become acquainted with the program layout and how to enter 
employee information. Throughout this chapter, there are examples of different program screens. 
You may wish to view the sample database to get a better picture of how employee records look 
once entered. 

Make sure you have gathered the following information for each employee before attempting to 
enter employee records: 

• Social Security Number 
• Name (First, Middle, Last)* 
• Employee Identification Number 
• Date of Hire* 
• Job Title 
• How many hours in a normal day the employee works* 
• Location* 
• Department* 
• Full or Part Time* 
• Active, Inactive or Terminated Status* 
• Time-Off Plan (Vacation, Sick, Personal, etc.)* 

 

* Required fields 



The Program Bar 
The Program Button in the upper-left corner allows you to select the Gradience program you 
wish to use and displays its features in the Feature Column. 
 
The programs are color coded as follows: 
 
Gradience Attendance 2008 –Green 
GradienceRecords 2008 –Red 
Gradience TimeClock 2008 –Purple 
  

  



Employee and Manager Access Levels 

There are two main levels of security to Gradience TimeClock: Employee Level and Manager (or 
Administrator Level).  
   
Employee Level Access – This only allows access to Clock In/Out and access to the My 
TimeClock feature, which will allow individuals access to their timecard histories. This also will 
allow them to create new time entries, edit existing entries, and/or delete their existing entries. 
Access to the In/Out Board may also be given. (See Employee’s TimeClock Access.) Setting 
up employee-level access consists of setting up access on the TimeClock Access screen. 
   
Manager Level Access – This will allow managers access to selected employee timecard 
entries. They may create, edit and delete entries for these employees. They’ll also have access 
to the In/Out Board. Managers at least may have access to everything or only a few 
Administration screens. Having one Manager Login that has access to everything is required. You 
may create other Manager Logins that have partial access to the Administration screens they 
need. For example, a payroll administrator may need only access to View/Edit Employee’s Time 
Card Entries, Create & Edit Work Schedules and to Timecard Runs. The other screens would be 
set for No Access. (See User Security.) 
   



The Feature Column 
 
 

TheFeature Column allows you to select which feature will be displayed in the Feature Pane on 
the right side. To make it easier, we also color-coded the features of each program. For example, 
if you select Gradience TimeClock, and select Employee Detail from the feature column, you will 
see a purple title bar. 
The Employee Select Column 
The Employee Select Column allows you to select or find employees quickly and easily, as well 
as select multiple employees for printing reports. 
Browse mode allows you to perform an incremental search for an employee, move columns and 
sort quickly. 
An incremental search allows you to enter the first couple of letters of the employees’ last name 
and will go to the first employee which matches those letters; and as you enter more letters, the 
search will become more defined. For example, if you enter the letter “A” in the Search field, the 
employee list will select the first employee name which starts with the letter “A.” If you enter the 
letter “d,” so that now you have “Ad” it will bring up the first employee name which starts with Ad, 
such as Adams. 
You may move columns according to your preferences. To move a column, click and drag the title 
to the left or right. Double arrows pointing inward will show you where you will drop the title if you 
release the mouse button. 
Sorting fields is just as easy. Just click on the title of the column you want to sort. For example, if 
you wanted to sort by first name, you would click on the First Name title. You can also set 
multiple sorts by holding the CTRL key and clicking on fields - the sort priority will be displayed 
above the field names. 
Tree View mode allows you to find or select employees by location and department. For 
example, if you were looking for employees who are under the Ft. Lauderdale location / 
Merchandising department, Tree View mode could show you at a glance. 
Tip: In Tree View, by default all locations and departments are unchecked. A quick way to select 
just one department is to click on the name of the department. This will select all employees 
under that department. Likewise, in Browse mode, you can select or deselect all employees by 
clicking on the red checkmark at the top left. 
Selected Feature Pane 
The Feature Pane is where the selected feature of the program will be displayed.  
  
Note: Columns can be resized. To resize a column, move your cursor to the left or right edge of 
the column until your cursor turns into a double arrow pointing left and right; click and drag your 
left mouse button to the desired width and release. The Employee Select Column can also be 
hidden and unhidden by clicking on the minus or plus sign in the top right corner. 



TimeClock Entries       

The TimeClock Entries feature allows you to maintain employee time entries. You may create 
new entries, as well as edit or delete time entries. You also may print out employee timecards 
from here.  
   
All changes (edits or deletions) are recorded and tracked. Selecting Show Changes will allow 
you to view entries that have been edited. A plus sign (+) to the right side of an entry denotes that 
an entry has been modified.  
   
   
Tip: Double-clicking on an entry in the changed window (at the bottom) will bring up details of the 
entry. 
   



TimeClock Entries Toolbar 

From the TimeClock Entries screen, Managers have access rights to create, edit or delete 
employee time entries.  
   



Creating a New Time Entry 

You must be given rights to this feature. Clicking New, from the TimeClock Entries feature, will 
give you the New Entry window with the following options:  
   

 
   
After clicking on New from the TimeClock Entries screen, you’ll be given the choice of Clock In / 
Clock Out or Enter Hours.  
   
Selecting Clock In/Clock Out will allow you to enter a manual punch entry just as if an employee 
had clocked in or out. For example, you may enter a manual punch entry of 05:15 PM for a 
specific date.  
Feature Description 
Reason for 
Change 

A Reason is required for Creating a Manual TimeClock Entry or Entering Hours for a Date. 

Date This is the date of the punch entry. 
Punched This designates In or Out of the punch. 
Time This is the time of the punch entry. 
Work Date This is the Work Date that the punch refers to.  
Comments Comments are not required but may be helpful when reading a reason at a later date. 
   
Selecting Enter Hours will allow you to give a set amount of hours for a given date. For example, 
you may enter a manual time entry of eight hours Vacation.  
Feature Description 
Reason for 
Change 

A Reason is required for Creating a Manual TimeClock Entry or Entering Hours for a Date. 

Feature Description 
Date This is the date the employee will get credit for.  
Work Date This is the Work Date that the punch refers to.  
Hours  This allows you to enter specific hours for a date, such as eight hours for a Vacation day. The Date, 

Hours and Reason for New Entry fields are required. 
Count 
toward 
overtime 
calculations 

Designates entry to count toward overtime. 

Comments Comments are not required but may be helpful when reading a reason at a later date. 
   



Date Versus Work Date 

When creating a new time entry, there are two date fields: Date and Work Date. The Work Date 
represents the date the entry is counted toward. Normally, you won’t need to change the Work 
Date unless you have work shifts that goes past midnight. For example, Josh starts work and 
clocks in at 8 PM on Monday night. He gets off work at 4 AM on Tuesday morning, but forgets to 
clock out. A manual time entry is created for him, punching him out at 4 AM; the Work Date is of 
the previous date (the actual date Josh started work). The program knew that Josh had clocked in 
at 8 PM the previous day, and because he had not gone over 13 hours between punches, it 
counted the OUT punch to the previous date. 
   



Editing a Time Entry  

Edit allows you to change an existing entry. You must be given rights to have this feature. 
Remember that the Reason for Change is required and tracked. Editing a time entry is similar to 
creating a new entry except you only have the choice to change a punch time entry. 
   



Deleting a Time Entry 

Delete will erase the selected time entry and record the deletion. All changes and deletions are 
recorded and tracked. To view deleted time entries, go to Reports > Deleted TimeClock 
Entries.  
   



Printing an Employee Timecard 

Print allows you to print an employee timecard for the selected date range.  
   



Getting Help 

Help allows you to bring up the help file for this screen. 
   



Timecard Entries 

The timecard entries have the following coding: 
Feature Description 
Blue 
band 

A blue band designates the selected entry. 

White 
band 

A white band designates an IN punch. 

Teal 
band 
(bluish 
green) 

A teal band designates an OUT punch. 

Gray 
band 

A gray band designates that a manual entry was given for a set amount of hours . For example, Josh 
took eight hours of Vacation on 3/15/2002, and a manual entry was entered for his time.  

Plus (+) 
Sign 

A plus (+) sign designates a punch was changed or manual entry was entered. 

Asterisk 
(*) 

An asterisk (*) designates that there is a double-punch; either two IN punches or two OUT punches 
together. Action should be taken on such an entry of either adding a new entry or correcting an 
existing entry. Hours cannot be calculated for a double-punch entry.  

   
CAUTION: If you see an asterisk (*) next to a time entry this means that some action should be 
taken, such as correcting a punch.  
   
Tip: Right-clicking on an entry will show you the rounding rules (Work Schedule Rules) for that 
entry. 
   



IN/OUT BOARD       

The In/Out Board allows you to see, at a glance, employees who are in and out. The In/Out Board 
will refresh itself if the Auto Update feature is checked. Otherwise, clicking the Refresh button will 
update the board.  
Feature Description 
Auto 
update 
every __ 
minute(s)  

This allows you to set how often this board should update for you.  Note: This is not a “live” board 
and will only be updated by the Auto Update or pressing Refresh. 

Feature Description 
In/Out 
Employees  

This allows you to see at a glance employees who are In or Out. 

Refresh Clicking this button will refresh the list. 
Help This gives you help regarding the current screen. 
Color-
coding: 

a.   Green – denotes employees who are clocked IN. 
b.   Teal (bluish-green) – denotes employees who are clocked OUT.  

   

Administrators can have access to view all locations and departments or only specific locations 
and departments depending on their security access rights. Employees may be given access to 
all locations and departments or their specific location and/or department or no access to the 
In/Out Board. (See In/Out Board Access under TimeClock Access.) 
   



Adding a New Employee       

Click Employee Detail Feature column. 
   

The Employee Detail screen allows you to add, edit and delete employees and, if installed, 
shares common screens with Attendance (Category Assignments) and Records (EEO and 
Personal Contacts). To add a new employee, follow these steps: 

1. Click from the Employee Browse or Employee Detail screen. 
2. As a minimum, enter First Name, Last Name, Hire Date, Employment Status, Work Status, 

and Location and Department. These fields are required. (To set up locations and 
departments, see Locations and Departments under Administration.)  

3. Click Save.  
   
NOTE: The SSN is not required when entering an employee in Gradience. However, when 
exporting timecard entries, if one of the selected payroll formats requires the SSN, you will need 
to enter it before exporting. 
   
   



Deleting an Employee       

   
CAUTION: This will delete ALL information on the current employee including any records 
in Gradience Attendance and Gradience Records. 
   

To delete an employee, and all associated records, follow these steps: 
1. From Employee Detail, select an employee by clicking on his or her name. 
2. Select File > Delete Employee. 
3. Click Yes to the “Are You Sure?” message.  

   



Giving Employees Access to Clock In  

Click TimeClock Access from the Feature Column. 
   

The TimeClock Access screen allows you to set up employee logins/passwords, swipe card 
access, individual access to create, edit and delete timecard entries, assign Work Schedules, and 
employee In/Out Board access. A manager or administrator always will have access to the In/Out 
Board screen.  
Feature  Description 

Employee, 
Location, 
Department  

This is shown to make it easier when assigning access. 

Search By  This allows you to search by Last Name, First Name, SSN or ID. 

Search For  Entering one character at a time will do an incremental search. For example, entering the letter “K” 
will bring up the names that start with K. Adding an L will search out names with KL and so on.  

TimeClock 
Identification 
(Changing 
Employee 
Password) 

TimeClock Identification allows you to change the selected employee’s Login and Password. Just 
enter the new Login and Password and click on Save to change. 

Swipe Card ID For the Swipe Card ID option, you’ll need a magnetic swipe card or barcode reader and pre-encoded 
cards. To assign a pre-encoded swipe card, click on Update/Change, then swipe the card through the 
swipe card reader. If an employee has an assigned swipe card ID number, you also will have the 
option to Clear/Delete.  

TimeClock 
Access  

   

TimeClock Access assigns employee options for: 

a.   Enable Employee TimeClock Access – This allows the selected employee to clock in and out. 
This is required to be selected if the employee is allowed to clock in/out.  

Feature  Description 

TimeClock 
Access (cont.) 

b.   Can create their own TimeClock Entries – gives employee the ability to create TimeClock entries. 

c.   Can Edit their own TimeClock Entries – gives employee the ability to edit TimeClock entries. 

d.   Can Delete their own TimeClock Entries – gives employee the ability to delete existing entries. 

Current Work 
Schedule 
Note: To 
create a Work 
Schedule, see 
Chapter 8- 
Creating and 
Editing Work 
Schedules. 

Current Work Schedule allows you to assign a Work Schedule for rounding and reporting purposes.  

b.   Clear allows you to remove this work schedule from an employee.  

c.   History allows you to view changes to an employee's work schedule. This also allows you to edit 
the Start Date.  

In/Out Board 
Access  

In/Out Board Access allows you to assign an employee access to see None, All employees, or 
employees by Location or Department. (See In/Out Board on page 83.) 

   



Employees Not Rounding on the Correct Work Schedule        

Employees may be assigned different rounding rules over the course of their employment. Every 
time an employee gets a new work schedule, he or she gets a new Start Date from which the 
current work schedule begins. A new work schedule will round only from the Start Date going 
forward. Any punches before this date will not be rounded on this schedule.  
   

There are times when you may need to change the start date for rounding calculations. For 
example, if an employee accidentally was assigned the wrong work schedule for a week in which 
the work schedule assigned was rounding him/her at 10 minutes instead of at 6 minutes, you 
would want to change to the new work schedule and have the program calculate all past punch 
entries.  
   
The work schedule start date is edited through the History Tab on the TimeClock Access 
screen. For example, if the start date is 11/5/01, rounding will occur only from this date forward. 
Any punches before this date will not be rounded on this schedule.  
   
CAUTION: Editing the Work Schedule date may affect punches for the current employee that 
have already been paid for.  
   



Changing an Employee’s Work Schedule Date 

Changing an employee’s work schedule date and having the program recalculate according to 
the new work schedule is a two-step process: 
   

First Step (Change the Work Schedule Start Date) 
1. From TimeClock Access, click on History (Current Work Schedule). 
2. On the Work Schedule History screen, double-click on the Start Date you want to 

change. For example, if you want to change the Start Date of 04/18/2002 to 05/01/2002, 
double-clicking directly on the 04/18/2002 date will bring up an edit box. 

3. Enter the Start Date of the new work schedule. 
4. Leave the Ending Date blank if this is the most current Start Date.  
5. Click Save. 
6. If you need to have time punches recalculated according to the new work schedule, go to 

the Second Step below; otherwise, punches may not have their time calculated correctly. 
   

Second Step (Recalculate the Punch Time Entries)  
You’ll need to edit any punch time entries that need to be recalculated and click Save. The act of 
clicking the Save button will recalculate the selected punch time entry according to the new work 
schedule.  

1. From TimeClock Entries, select the employee and the punch time you wish to 
recalculate.  

2. You may select the punch time entry either by double-clicking on the punch entry or by 
highlighting it (by clicking once on the entry) and selecting the Edit icon.  

3. Do not change the date or time. Select a  Reason for Change. (You cannot save an entry 
without selecting a reason.) 

4. Click Save.  
5. Repeat the above steps for any punches that need to be recalculated.  

Clicking Save will recalculate the punch time entry according to the work schedule. For example, 
if you changed this employee’s work schedule from 10-minute rounding to 6-minute rounding, 
then saved any punch entries that fell within the Start Date, his/her punch entries would be 
recalculated. 
   
   



Reminders 
The Reminders feature will show you all open (unresolved) reminders and allow you to create, 
delete and resolve reminders. If you have created a reminder it will show up when you first open 
the program, starting on the reminder date. Reminders will continue to display until you click 
Resolve. 

  

Reminders Tool Bar and Pane Layout 
  

Tool Bar: 

• First-Prior-Next-Last arrows– navigates through selected reminders 
• New– Creates a new reminder 
• Edit– Allows you to make changes to a reminder 
• Save– Saves reminder 
• Cancel– Cancels current changes 
• Delete– Deletes selected reminder 
• Print– Lets you print the Reminders report for selected employees 
• Help– Brings up help for this screen 

Pane Layout: 

• Reminder Date– Date reminder should first display 
• Title– Heading of reminder 
• Resolved– Checkbox displays checked for resolved or unchecked for open (unresolved) 
• Employee Name– Displays name of employee that reminder is associated with 
• User– Displays name of user that reminder will display for 
• Description– The purpose of the reminder shows here 

Filters: 

• User– Allows you to view reminders associated with specific users (must have access to 
Reminders, Assign Users under User Security) 

• Show Resolved– Displays Resolved reminders only 
• Show Unresolved– Displays Unresolved (open) reminders only 

Use Date Filters: 
The From Date and Through Date filters can be enabled here to show Reminders only for the 
selected date range. 

  

Creating a New Reminder 
There are two types of reminders in Gradience: 
One Time Reminders– These are reminders that are only meant to remind you of a one-time 

event, such as filing an Absence Report at the end of the year. 

Recurring Reminders–These remind you of the following recurring events: 

• Anniversaries (Gradience Attendance) 
• Birthdays, Performance Reviews, and I-9 Renewals (available if Gradience Records 2008 is 
also installed) 

  

Setting a Reminder 
One Time Reminder 

1. Click on Reminders from the Features Column. 
2. Click New.  
3. Select (check) One Time Reminder. 
4. Enter a Title and Reminder Date. 



5. If you want the reminder to be associated with specific employees, select the checkbox 
“Assign to all selected (checked) employees.” This is optional and will create a 
separate reminder that is associated with each employee. 

6. If you selected the checkbox in Step 5, you will need to select (check) any employees that 
this reminder is about in the Employee Select Column. Otherwise, skip to the next step. 

7. By default, the User’s name will default to the login that was used to enter the program. 
Change this if you want the reminder to come up for another user, or you may select 
Global which allows the reminder to come up for all users logging in.Note: You must have 
access to Reminders, Assign Users and Reminders, Assign Global under User Security to 
be able to change this option. 

8. Enter a description of the reminder, if needed. 
9. Click Save. 

Recurring Reminder 
1. To create a recurring reminder, follow these steps: 
2. Select Reminders from the feature list. 
3. Click New. 
4. Select (check) Recurring Reminder. 
5. Select the type of reminder: Anniversary, Birthday, I-9 Renew, or Performance Review. 
6. Select a Through Date (when do you want to stop the reminder from occurring). 
7. Select how many days you want to be reminded before the event. 
8. By default, the User’s name will default to the login that was used to enter the program. 

Change this if you want the reminder to come up for another user, or you may select 
Global, which allows the reminder to come up for all users logging in.Note: You must have 
access to Reminders, Assign Users and Reminders, Assign Global under User Security to 
be able to change this option. 

9. Enter a description of the reminder, if needed. 
10. Click Save. 

Deleting Reminders 
Reminders are deleted from the Main Reminders screen by clicking on the Delete icon. 

  

Editing Reminders 
There are two ways to edit reminders: 

1. Main Reminders screen -From the main Reminders screen you can edit the following 
columns just by clicking in the field: Reminder Date, Title, Resolved and Description. 

2. Edit Reminders screen -Clicking on Edit from the main Reminders screen will bring up 
the Edit Reminder screen. You may also double-click on the title of a reminder. The Edit 
Reminders screen allows you to change the Title, Reminder Date, User and Description. 

Note: If you need to change the Employee Name that this reminder is about, you’ll need to delete 
the reminder and then re-add it. 

  

Open Reminders 
Open reminders will appear for the user they are assigned unless the Global option is checked. If 
a reminder is marked with Global, then it will show for all users. You may view open reminders by 
opening the program or selecting Reminders from the feature list. 
Note: If you have security access to “Reminders, Assign Users” (SeeUserSecurity), you may 
view reminders set up by other users. You may also resolve reminders from the Open Reminders 
screen. 



Creating and Editing Work Schedules 

This section will allow you to set up your work schedule rules and define your daily work hours for 
reporting purposes. 
   

As a rule, many businesses allow a grace period for employees when clocking in or out. This 
allows for time variations on clocks, watches and time devices throughout a company. Rounding 
time also makes calculating payable time easier.  
   



Rounding Explained        

Gradience TimeClock can automatically round off in 2-, 3-, 4-, 5-, 6-, 10-, 12-,15-, 20-, 30- and 
60-minute intervals, and it will calculate the time in decimals, unlike many mechanical time clocks. 
This saves time by not having to convert the minutes to decimals. Note: If you don’t round, then 
select the Generic – No Rounding rule. 
   

TimeClock rules can be assigned to individuals or groups. Rules usually are defined for punching 
IN early or late and OUT early or late. 
   

EXAMPLE 

Here is an example of rounding using the 15-minute rule: 
   

Richard comes in a few minutes early and clocks in at 07:55. 
Tanya is running late and clocks in at 08:04. 
   
Using the 15-minute rule, both Richard's and Tanya’s payable time would be clocked in at 08:00. 
Their time was rounded to the nearest 15-minute mark. The next 15-minute mark would be 08:15, 
then 08:30, and so on.  
   
However, using the 6-minute rule and the above clock-in times, Richard’s payable time would be 
clocked in at 07:54. The next 6-minute mark for Richard would be 08:00. Tanya’s payable time 
would be clocked in at 08:06. The next 6-minute mark would be 08:12, 08:18, and so on. Their 
time was rounded to the nearest 6-minute mark. 
   

Gradience TimeClock comes with three commonly used rounding rules: 6-minute, 10-minute and 
15-minute generic rules that are set up to round to the nearest mark. You may choose one of 
these and rename it or set up your own.  
   



Work Schedule Rounding Rules  

Go to Settings > Work Schedules. 
   

The program comes with three commonly used rounding rules. You may use one of these and 
rename it or create your own.  
   

The Rounding Rules Tab has the following features: 
Rounding 
Rules  

Description 

Work 
Schedule 
Name  

Name the Work Schedule here.  

Time 
Credited in 
__ Minute 
Increments  

This allows you to select rules for increments up to 60 minutes (increments must be divisible by 60).  

Rounding When the Time Credited in __ Minute Increments is selected, the default rounding is set to round 
to the nearest credited increment. You may change this setting to fit your needs. Use the Rounding 
Example to test your changes. 

Rounding 
Example  

This allows you to see how your rounding will affect true clocking in/out punches. Set the Hour and 
Minute to test how rounding will affect punch times. 

   

   

The Overtime and Punch Schedule Tab has the following features: 
Overtime 
and 
Punch 
Schedules 

Description 

Payroll 
workweek 
starts on 
… 

This determines the day that your work week begins on, which is defined as the start of the pay 
week.  

This 
Schedule 
Qualifies 
for DAILY 
Overtime 
after __ 
Hours  

Select this option if your policy is to give overtime after working so many hours on a DAILY basis. 
(For example, anything more than 10 hours daily is considered overtime.) 

This 
Schedule 
Qualifies 
for 
WEEKLY 
overtime 
after __ 
Hours  

Select this option if your policy is to give overtime on a WEEKLY basis. (For example, anything more 
than 40 hours weekly is considered overtime.)  

Daily 
Schedule  

This allows you to set up daily schedules that can be reported on. (For example, if you wanted to 
know who was 15 minutes or more late on Mondays, you could run an Exceptions report.)  

This is a 
Workday 

This designates the selected day as a regular workday. 

This is an This designates the selected day as an overtime day. 



Overtime 
Day 
Quick 
Copy 
Schedule 
From 

After you set up the first workday, this allows you to copy it to the next workday so you don’t have to 
re-enter the same hours. 

New Time 
Entry 

This allows you to enter a new entry for your employees daily work schedule.  

Delete 
Time 
Entry 

This allows you to erase an entry.  

   



Shifts Crossing Workweek       

Gradience TimeClock will automatically ensure that your time entries are fully compliant with 
federal labor laws and workplace regulations regarding shifts that cross workweeks. 

If an employee works during a time period that crosses from one workweek into another, 
Gradience TimeClock will automatically enter a Punch/Time Entry on the 59th second of the 
current workweek.  This Punch/Time Entry will appear on the employee’s timecard as WK End*. 

Gradience TimeClock will immediately follow the WK End* Punch/Time Entry one second later at 
the start of the new workweek with another automatic Punch/Time Entry. This second 
Punch/Time Entry will appear on the employee’s timecard as WK Start*. 

Although the hours worked on the first day of a workweek will be short, these hours will be 
supplemented with the hours worked on the last day of the same workweek, thereby allowing the 
employee to be credited for a full week. 

Below is an example.  In this example, the program has been set to display time in military time. 
 

 

   



Manual TimeClock Entries 

Follow these steps to manually enter a punch or to manually enter a block of hours for an 
employee.  

Steps:  

1. Click TimeClock Entries on the left  

2. Select an employee.  

3. Near the top-center of the screen, under the heading TimeClock Entries, click New.  

4. On the drop-down menu, select either Clock In / Clock Out or Enter Hours.  

5. Depending on your selection in step 4, one of the two pop-ups shown here will open.  

6. Under Reason for Change a menu provides selections that were set up previously in the Reason 
Codes portion of the program. (Settings > Reason Codes > New) shown below: 
 

 
 
Note: If the reason for your entry is not available, you’ll need to cancel out and click Settings > 

Reason Codes. Then, select or create the Reason Code, check Enabled and check the desired 
purposes for the Reason Code.  



7. Under Date use the menu to select a date within the Work Date Range shown on the 
TimeClock Entries screen. shown below: 
 

 

 

 

8. Make appropriate selections for the following …  

• Kind of punch whether In or Out 
• Time of day, AM or PM 
• The Work Date references the date on which the entry occurred.  
• The Date references the date to which the entry applies.  
• Shift. (Established previously when setting up the Work Schedule)  



• Comments you may have.  
 

 

9. Click Save.  



Schedule Overtime Rules 

Follow these steps to instruct TimeClock on how to manage overtime:  

1. Click Settings > Work Schedules.  

2. Click New to create a new work schedule or select an existing work schedule from the list on 
the left.  

3. When the work schedule opens on the right, click the Overtime and Punch Schedules tab near 
the top.  

Under Schedule Overtime Rules, you have three options:  

•  The first option allows you to instruct the Work Schedule to consider time worked on a 
single day (beyond a number of hours that you set) as overtime. This is a requirement in 
some states but also may be used as an organizational perk elsewhere.  

• The second option allows you to instruct the Work Schedule to consider time worked 
beyond 40 hours in a single workweek as overtime.  

• The third option will be selected automatically when you select both option one and option 
two. This is to allow overtime to be calculated correctly when overtime is permitted on both 
a daily and a weekly basis. Without this option, overtime could be counted twice. If you 
only select option one or option two, this option is unnecessary.  

EXAMPLE:  
 If an employee works 10 hrs on Monday and you set the Work Schedule to count anything 
worked beyond 8 hrs in a day as overtime, he/she would at that point have 8 hrs of regular time 
and 2 hrs of overtime. If this same employee worked 8 hrs a day for the next four days, he/she 
should have 40 hrs regular and 2 hrs overtime, but without the third option being selected he/she 
would get 38 hrs of regular and 4 hrs of overtime. This is what is meant by compounding or 
pyramiding, which the third option prevents.  

IMPOPRTANT!  
Simply “creating” a Work Schedule is not enough. You must assign a Work Schedule to each 
hourly employee for overtime to be credited properly. Work Schedules do not need to be 
assigned to salaried employees.  



 

 



More About Rounding       

Gradience TimeClock rounding is based on three points: 
1. What you select for Time Credited in Minute Increments 
2. What you set for Clocking In and Out rounding 
3. Assigning the Work Schedule to an employee through TimeClock Access.  

Gradience TimeClock automatically rounds to the nearest mark based on your choice of minute 
increments. Gradience TimeClock will round up or down at about the halfway mark. For example, 
if you’re using Gradience TimeClock to credit in 6-minute increments, then the program will round 
up AFTER 3 minutes and round down before this time. The key word is AFTER. The program will 
ROUND UP AFTER however many minutes you select.  
   

Gradience TimeClock allows you to select rounding up to the designated credited amount, minus 
one minute. If you choose to credit in 6-minute increments, then you could choose from 1 to 5 
minutes for rounding. If you choose to credit in 10-minute increments, then you could choose 
from 1 to 9 minutes for rounding and so on. 
  
  TIP: If in doubt, use the Round Test to see how the time will be rounded. 

   



Setting up a Work Schedule       

Setting up a Work Schedule allows your employees' punch times to be rounded and allows you to 
report on various settings according to the Work Schedule. For example, if you wanted to know 
who was clocking in late on Mondays in June, you could run an Exceptions report. All employees 
who clock in/out must be assigned a Work Schedule for rounding and reporting purposes.  
   

To set up your work schedule, follow these steps: 
1. Click New. 
2. Enter a descriptive work schedule name. 
3. Select how your time is credited for rounding purposes. 
4. If you round to the nearest mark, you may leave the defaults in the Rounding block as they 

are. If, however, you round nearer or farther from the nearest mark, then you may change 
the rounding to suit your needs. 

5. Check how the program will round for you by entering a clock in/out time in the Rounding 
example block. If the time isn’t rounding the way you want, then change the Rounding time 
and check it again. 

6. Select whether this work schedule qualifies for DAILY overtime and after how many hours.  
7. Select whether this work schedule qualifies for WEEKLY overtime and after how many 

hours. 
   



Setting up the Daily Schedule       

To define the daily schedule, follow these steps: 
   

1. Select a day of the workweek and specify whether it is a Workday and/or an Overtime Day. 
An Overtime Day is any day that is automatically counted as overtime, such as Saturday or 
Sunday.  

2. Click New Time Entry:  
1. Enter what time employees on this work schedule normally would start work. Press 

the TAB key or click New Time Entry to go to the next row. 
2. Enter what time the employees normally would break for lunch. Press the TAB key 

to go to the next row. 
3. Enter what time the employees normally would come back from lunch. Press the 

TAB key to go to the next row. 
4. Enter what time the employees normally would leave for the day. 

3. Click on the next day and enter his/her start and end time for this day. You also may use 
the Quick Copy Schedule feature to copy the previous day’s entry. Click Save to save this 
work schedule. 

   

Remember to assign a work schedule to each employee under TimeClock Access; without an 
assignment, employee entries and overtime will not follow the Work Schedule rules. This can 
result in payroll errors. 



Preparing Timecard Runs  

Timecards are prepared by the Payroll Administrator or other designated person who can run 
timecard reports or export this data to your payroll program. The person who has access to 
Timecard runs can lock out employees and other managers from making any changes to specific 
date ranges and save this information so changes cannot be made to time that already has been 
paid for.  
   



Viewing Timecard Data       

When viewing timecard data, keep in mind that overtime will show only if you have set up a Work 
Schedule and assigned it to your employees. The Work Schedule will have rules regarding 
overtime and what day your Workweek starts on. See Work Schedules.  
   



Frequently Asked Questions 

Q: I’ve created a timecard run covering eight days. For one employee it shows 59 hours of 
worked time, but zero hours of overtime. Why is this? 
A: The start of your Workweek (set in the Work Schedule) determines the week for overtime. 
Check to make sure you have a Work Schedule assigned for this employee by going to 
TimeClock Access > Current Work Schedule. If there is one, go to Settings > Work 
Schedules and make sure the assigned Work Schedule has the appropriate overtime settings. If 
the overtime settings aren’t set up, then go to Work Schedules and create one before assigning 
it. (See Creating Work Schedules for detailed information.)  
   
For Example: If a timecard run is created to include Randy from (Wed.) August 8, 2007, through 
(Thur.) August 16, 2007, and it shows that he worked 59 hours during this time, this doesn’t 
necessarily mean he has overtime. Weekly overtime, if any, is calculated on the last day worked 
of the workweek. Daily overtime, if any, will be calculated on the same day worked. 
   
   
August 

2007 
Sun Mon Tue Wed Thur Fri Sat 
         1  2  3  4 
5 6 7 8 9 10 11 
12 13 14 15 16 17 18 

19 20 21 22 23 24 25 
26 27 28 29 30 31    
   
Assuming our Workweek starts on Sunday, the date range of August 8 – August 16 covers two 
separate Workweeks. (Workweek 1: August 5 – August 11 and  Workweek 2: August 12 – 
August 18.) If Randy does not work overtime on a daily basis or for the whole workweek, he won’t 
have any overtime. But, if he does work overtime for Workweek 1, it will be calculated for that 
Friday (August 10) and be included on the report. Overtime worked for Workweek 2 will not be 
reported unless Friday, August 17 is included.  
Factors involved in calculating overtime: 

1. What is the Workweek Start Day? (Sunday? If the workweek starts on Sunday, this would 
mean the workweek is from Sunday through Saturday every week.) 

2. Do your employees receive overtime based on time worked on a daily basis? (Example: 
Daily time worked over 10 hours receive overtime.) 

3. Do your employees receive overtime based on time worked on a weekly basis? (Example: 
Weekly time worked over 40 hours receive overtime.) 

4. When was the Work Schedule assigned to the employee? 
Overtime Description 
Daily 
Overtime 

Overtime will be posted on the day the employee goes over the amount of hours set for Daily 
Overtime on the Work Schedule. (Example: if > 10 hours daily is considered overtime; if employee 
works more than 10 hours on Tue, overtime will be shown same day.) 

Weekly 
Overtime 

Overtime will be posted on the last day worked on the workweek. (Example: if > 40 hours a week is 
considered overtime; if employee works Mon – Fri, overtime will be shown on Fri.) 

   



Exporting TimeClock Data       

You may export time entry data two different ways in Gradience TimeClock. The first way is from 
the Export feature under Timecard Runs. The other way is from Export TimeClock Data under the 
File menu.  
Export 
Type 

Description 

Export 
TimeClock 
Data 

Exports hours worked and general employee information to a .csv file. This is a general export found 
under the File menu. 

Time Card 
Runs 
Export 

This is a specific export feature that exports to several different payroll formats. 



Timecard Runs Export 

From Timecard Runs Export you may export to a text file into the following Payroll formats: 

• ADP/PC Payroll for Windows 
• Paychex 
• PaycomOnline 
• PayAmerica 
• QuickBooks Pro and Premier Editions 2003 and above 
• RDE (Summit Payroll Express) 
• Rapid Payroll 
• UltiPro 

Please call or e-mail Tech Support for other formats. 
   

*Gradience TimeClock is integrated with QuickBooks. When you click on Export, the time data is 
automatically transferred into QuickBooks. (See QuickBooks Integration below.) 
   



QuickBooks Integration 

Gradience TimeClock can import time data directly into QuickBooks Pro and Premier Editions 
2003 and/or 2004. To import from Gradience TimeClock, you will need to set up QuickBooks for 
the following: 

• to view Weekly TimeSheets 
• appropriate Payroll Items that correspond with Gradience TimeClock 

   
NOTE: Gradience TimeClock and QuickBooks should be set up before performing the following 
steps. 
   

The following steps will set up Gradience TimeClock to import directly into QuickBooks: 
1. Open QuickBooks. 
2. Open Gradience TimeClock. Check your version number by going to Help > About. You 

should have at least v1.4.1.1 or higher before continuing.  
3. From within Gradience TimeClock, go to Timecard Runs and select Export. 
4. If QuickBooks isn’t an option in the left column, hold down Ctrl-Alt-Q to display it. 
5. Click Open QuickBooks. This will bring up a QuickBooks message asking: Do you want 

this application to access your QuickBooks Company File?  
6. Select “Yes, Always” or “Yes, This Time” to allow access. Click Yes if you receive the 

Confirm to Proceed message. Note: If you select “Yes, This Time,” the next time you open 
QuickBooks from Gradience TimeClock it will ask you again for access. 

7. Click back on Gradience TimeClock. You should see two columns that may be filled in with 
data already. The Payroll Code column are codes related to Gradience. The Payroll Item 
codes are related to QuickBooks. You’ll need to relate the appropriate Payroll Code from 
Gradience to the Payroll Item code in QuickBooks. The Gradience Payroll Codes should 
be displaying. Clicking in the corresponding row for the QuickBooks Item code will bring up 
a drop-down box. 

8. Click Save after making any changes. 
9. Click Export. 



Exporting TimeClock Data 

From File > Export TimeClock Data, you may export hours worked and general employee 
information to a .csv file, which can be opened in MS Excel or other spreadsheet programs.  
   

The TimeClock Export feature allows you to export the following data: 
Last Name Location 
First Name Department 
Middle Name Punch Hours 
SSN Punch Changes 
Date of Birth    

   

Features Description 
Export 
Type 

• Single File – Exports Employee Data and Hours Worked to a single file. If Export Punch 
Changes is selected, it will export to a separate file in addition to the Hours Worked.  

• Relational File – Exports Employee Data and Hours Worked to two separate files. If Export 
Punch Changes is selected, it will export to another separate file.  

Export This exports the data once you have settings complete. 
Select 
Employee 
to Export  

This allows you to select specific employees, locations and/or departments to export. 

Hire Range 
Filter  

This allows you to filter on a specific hire date range.  

Job Status 
Filter  

This allows you to filter on full and part time. 

Employee 
Status 
Filter  

This allows you to filter on Active, Inactive or Terminated employees.  

Select 
Employee 
Data Fields 
to Export 

• Available Fields – This is the list of fields to choose from. 
• Fields to Export (In Export Order) – These are the fields chosen. 

Export 
TimeClock 
Data  

• Export Hours Worked for Period – This allows you to select a date range for timecard data for 
the selected employee(s). 

• Export Punch Changes – This allows you to export punch changes. 
   

To export this data, follow these steps: 
1. From the File menu, select Export TimeClock Data. 
2. Select the export type: Single File or Relational. 
3. Expand the tree, if necessary, and select the employees to export. 
4. Select the data fields to export either by double-clicking on the file or selecting the file and 

clicking on the arrow pointing to the right. 
5. If needed, select the Export Hours Worked option with a date range. 
6. If Export Hours Worked is selected, you can select Export Punch Changes option. 
7. Click Export.  



  



Deleted TimeClock Entries Report       

   

The 
Deleted 
TimeClock 
Entries 
Report 
shows 
entries that 
were 
deleted 
along with 
the 
reason(s), 
comments 
and login 
name of the 
person 
deleting the 
record. 

 

   



Employee Anniversary Report       

   
The Employee Anniversary Report shows the hiring anniversary date of employees, according to 
the selected date range.  

 
 

   



Employee Summary Report       

   

The 
Employee 
Summary 
Report is a 
quick 
overview of 
one of your 
employees, 
showing 
SSN, date 
of hire, title, 
active 
status, and 
full-part-
time status. 

 

   



Exceptions (Punch)       

Exceptions are broken down into two separate reports: Punch Exceptions and Hours Exceptions. 
The Punch Exceptions report allows you to report on early or late clock in and out punches. You 
even may report on actual clock in/out time or on the rounded time.  
   
NOTE: Your employees must be assigned to a Work Schedule with the daily hours set up to 
properly view this report.  
   

The following are other options that are available on the Punch Exceptions Report. For a list of 
features not listed here, please see Report Interface Features above. 
Feature Description 
Report Date 
Range  

This allows you to set a date range for the report. 

Time Used 
For Report  

This allows you to report on Reported (actual punch time) or Rounded time.  

Punch 
Exceptions 
in Minutes  

This allows you to view how early or late, in minutes to report on.  

Work 
Schedule(s) 

This allows you to filter on a selected work schedule. 

Week 
Day(s)  

This allows you to filter on specific days. 

   



Exceptions – (Hours)       

The Hours Exceptions Report allow you to report on hours over or under by day, week or month. 
This report can be used to monitor which employees may be near overtime.  
   
NOTE: To properly view this report employees must be assigned to a Work Schedule with the 
daily hours set up.  
   

   

The following are other options that are available on the Punch Exceptions Report. For a list of 
features not listed here, please see Report Interface Features. 
Feature Description 
Report Date 
Range  

This allows you to set a date range for the report. 

Time 
Exceptions 
in Hours  

This allows you to report on total hours over or under by day, week or month, and to filter on a work 
schedule.  

Work 
Schedules  

This allows you to filter on a selected work schedule. 

   
   
   



Hours Worked Report       

   
The Hours 
Worked 
Report 
shows 
regular 
hours, 
overtime 
hours and 
total hours. 
You may 
select 
specific 
employees 
by date 
range. 

 

   



ID Badges       
You may create ID Badges for use with Gradience TimeClock or company identification. There are 
four kinds of ID Badges: Employee, Temporary, Guest or No Title.  

 
 



Layout 

The Layout Tab allows you to select what features will be on the ID Badge. For example, if you 
want the badge title to read Guest instead of Employee, you can select Guest under the Badge 
Title. 



Barcode 

The Barcode Tab allows you to select the type of Barcode that will be printed. If you’re not sure 
which type to use, we recommend keeping the default barcode type of Code 39. Gradience uses 
the Employee ID as the Barcode number. If an employee doesn’t have an Employee ID number, 
a barcode will not print out on the label.  
   



Print Stock 

The Print Stock Tab allows you to select the label type. The Gradience ID Badge type can be 
requested through our sales team and is specifically designed to work with Gradience TimeClock 
and Gradience Confidential Employee Record.  
   



Label Adjustments 

Printers are not created equally; some may print the labels too far to the right or left. The Label 
Adjustments Tab allows you to move the labels to the left or right and up or down, to 
accommodate quirky printers. Normally, you shouldn’t need to adjust the labels to the right and 
left or up and down, but it’s there in case you need it.  

Feature Description 
Left Offset When using the Left Offset, positive numbers will offset the label to the right and negative numbers 

will offset the label to the left.  
Top Offset When using the Top Offset, positive numbers will move the labels down, and negative numbers will 

move the labels up.  
Picture 
Offset  

The Picture Offset allows you to stretch the picture by using positive numbers and negative numbers 
will reduce the picture, if needed.  

Save Label 
Adjustment 

The  Save Label Adjustments button allows you to save your current settings.  

   
   



Report Interface Features       

The following features are available on each report interface: 
Feature Description 
Preview This allows you to see how the report will show when printed. 
Print This prints the report.  
Printer 
Setup  

This allows you to set printer options. 

Help This will allow you to view help regarding this screen. 
Close This exits the report interface. 
Grouping 
Options  

This allows you to group on Location and Department. 

Display 
Options  

This allows you to display SSN. 

Export 
Options  

This allows you to not export headers.  

   



Report List       

Here is a list of the reports you can run: 

• Emlployee Detail  
• Employee Summary  
• Employee Anniversary  
• Hours Worked  
• Deleted Time Clock Entires  
• Work Schedule Assignments  
• Exceptions  
• Time Cards  
• Time Card Runs  
• Time Card Runs Extended  
• Punch Location  
• Missing Job Codes  
• Job Code Hours  

   



Table Listings       

Table 
Listings 
allows you to 
print user 
access rights 
(User 
Security), 
Locations 
and 
Departments, 
which 
departments 
are assigned 
to locations 
(Assigned 
Departments) 
and Reason 
Code 
information.  

 

   

Table Listings are used mainly by Tech Support in assisting you with any issues but can be useful 
when setting up. For example, if you want to see what departments are assigned to locations, you 
can print a listing of Assigned Departments.  



Timecards Report       

The 
Timecards 
Report 
shows 
punch 
times and 
manual 
punch 
entries for 
each 
employee 
according 
to the 
selected 
work date 
range. 
Changes 
made to an 
entry can 
be printed 
along with 
employee 
and 
supervisor 
signature 
blocks.  

 
NOTE: Punch entries with an asterisk (*) to the right of the entry require attention. It means that 
double in or out punches have been made and need to be corrected.  
   



Timecard Runs (Extended)       

The Timecard Runs (Extended)  Report will print regular time, overtime and all Payroll Code 
Descriptions in a “row” format. If you have more than two payroll code descriptions (for example, 
Vacation, Sick and Personal), this report will allow you to view all payroll code descriptions set up 
under  Settings > Reason Codes – Payroll Code Description.  

 
 

   



Timecard Runs Report       

The Timecard Runs Report shows totals of regular time, 
overtime. 
  

It has been updated for 2008 with a filter to export Inactive or 
Terminated Employees with hours to show. 

 
   

To print a report, follow these steps: 
1. From the Reports menu, select the appropriate report. 
2. Select any options necessary from the filter and options settings. 
3. Under Select a Timecard Run, select a run.  Note: Runs must be created through the 

Timecard Runs Tab. 
4. Click Preview to see the report on the screen before printing.  



  



Using Reports 

Gradience TimeClock includes several powerful reports to help you manage employees and 
prepare for payroll. For additional reports, please try Gradience Records, which offers you the 
power of additional employee information tracking.  
   



Work Schedules Assignments Report       

   
The Work Schedules Assignments Report 
shows which work schedule each employee is on 
and when it was assigned.  

 



  



Backing Up  

How often should you back up? 
Every company is different regarding its backup needs. One thing to remember is, “It’s not if your 
computer is going to crash, but when.” They have made great strides in making computers more 
reliable, but that just makes the time longer before something can happen to your computer.  
   

The following pertains to any data on your computer and not just your Gradience program. Ask 
yourself this question, “If my computer were to crash right now, how long would it take to re-
create (reenter) all of my data without a backup?” Then ask yourself, “If I had to restore from a 
backup, would I be OK with last week’s backup, when I have to re-enter a week’s worth of data? 
Would I be OK with restoring a backup from three days ago? 
   

When restoring your data, the information will be only as current as your last backup. So, if you 
did a backup two weeks ago and had to restore this backup, you would need to reenter the data 
that didn’t get backed up.  
   

Back up after you make changes to your employee records.  
It is recommended that you back up your database after making any significant changes to 
records. For example, any time you enter several employees or input many changes to absence 
information would be a good time to back up. You also may set up the DB Monitor to 
automatically back up at assigned times.  
   

Rotate backups and store backup copies offsite.  
A good backup routine is to have at least three sets of backups covering different days of the 
week. This practice is called rotation and reduces your risk of data loss. It is also a good practice 
to always keep one copy offsite in case of a fire or flood. Consult your system administrator for 
your company policy regarding data storage.  
   
A Restore is when you recover from a backup. There are three different uses for the restore 
feature.  A Restore may be done only through the DB Monitor.  

1. To overwrite the current data with archived data. 
2. To recover from a hardware crash. 
3. To move information onto a new computer. 

   

Please keep in mind, when you restore data, your information will be only as current as the 
backup you are restoring from.  
   

IMPORTANT NOTE 
The backup file may be saved only to the Server or Standalone Computer where the database 
resides. The backup creates a zipped file with an extension of .gbk.  
   



Creating a Manual Backup from Within Gradience 

To perform a manual backup from within the Gradience program, follow these steps: 
1. From within Gradience, go to File > Maintenance > Backup > Backup Database. 
2. If you are running the backup utility from the Server or at a local PC in which the database 

resides (Standalone), you will have the option to select where you want to back up to. If 
you are running the back up utility from a Client (Gradience client install), it will 
automatically run the backup, saving the data where the database resides.  



Creating a Manual Backup from Within DB Monitor 

To perform a manual backup from within DB Monitor, follow these steps: 
1. Open the DB Monitor program by going to Start, Programs, Gradience Maintenanceand 

clicking on DB Monitor.  
2. Enter your login and password. If you do not have access to the DB Monitor Backup 

feature, you will need to see your administrator.  
3. Click the Backup Tab.  
4. Click Yes to the message,  “Do you want to perform a sweep after the backup 

completes?”  Note: A Sweep is a maintenance feature that keeps the database working 
at peak performance.  

5. Click OK at the Select Directory screen. It is highly recommended that you keep the 
default location.  Note: You may back up only to the Server or standalone computer where 
the database resides.  

6. Click Close when the backup is complete.  
   



Scheduling Automatic Backups 

To create a scheduled backup, follow these steps: 
1. Open the DB Monitor program by going to Start, Programs, Gradience Maintenance, 

and clicking on DB Monitor.  
2. Enter your login and password. If you do not have access to the DB Monitor Backup 

feature, you will need to see your administrator.  
3. Click the Backup Tab.  
4. Click New Backup.  
5. Enter the Backup Type by selecting Daily, Weekly or Monthly.  
6. Enter the military time when you would like the backup to take place.  
7. It is recommended to keep the other default settings of Performing Sweep and the path of 

the backup. A different backup will be created for each scheduled backup. Note: The 
name of the backup will be: [Type]_Backup_[mm-dd-yyyy]_[time] to distinguish it from 
other backups. For example, Weekly_Backup_08-02-2008_2300, or 
Monthly_Backup_09_01_2008_1700.  

8. Click Save. The backup will be performed within a minute of the scheduled time.  Note: 
The Server or standalone computer containing the database must be turned on for the 
backup to complete. If the computer is not on at the scheduled time, the DB monitor will try 
to create the backup the next time it is opened.  



Restoring from a Backup 

Remember, restoring a backup will overwrite all data in the current database. Restore may be 
run only from the DB Monitor on the Server or standalone computer. To restore, follow these 
steps: 

1. Go to the Server where the database files are stored. (Restore cannot be done from a 
Workstation.) 

2. Open the DB Monitor program by going to Start, Programs, Gradience Maintenance, 
and clicking on DB Monitor.  

3. Enter your login and password. If you do not have access to the DB Monitor Restore 
feature, you will need to see your administrator.  

4. Click the Restore Tab.  
5. Click the database to restore.  
6. Click Browse and double-click the backup you wish to restore.  
7. Click Start Restore.  
8. After Restore is complete, click Hide to minimize the DB Monitor.  

You may open the program to see your restored data.       
   



DB Monitor  

Go to Start > Programs > Gradience > DB Monitor. 
   

The DB Monitor allows you to change the Server Name and Database Path, Backup and Restore 
your database, view database information and clear inactive connections. It also will show you 
what Gradience version each client computer is running. This is good to make sure everyone is 
on the same program versions.  
Feature Description 

Settings This allows you to change the Server Name and Database Path.  
Backup This allows you to set up a backup schedule or back up now. See above for creating a backup. 
Backup History This shows all backups completed. You will need to manually delete old backups from within 

Windows Explorer. 
Restore This can be done only from the same drive in which the database resides. For example, if the 

database was on a Server, the restore could be done only FROM the Server, not from the Client 
Workstation. See above for steps on restoring. 

Information This allows you to view how many users are connected to the database and where the current 
database. The Server Version information is the version of Interbase (database).  

Statistics This gives information on the database. Normally you will not need this information.  

 
Connections This allows you to view who is connected and any inactive connections that need to be cleared.  

   

Clearing Connections 
Go to Start > Program Files > Gradience and select DB Monitor.  
   

To clear a connection, follow these steps: 
1. Make sure all users are out of all Gradience programs. 
2. From the Connections Tab of the  DB Monitor, click on the  Refresh button and make 

sure all Computer Names have an “N” under Active Connections. 
3. Click Clear Inactive Connections. This will clear all connections listed with an “N” under 

Active Connections. 



Performing Maintenance and Repairing the Database       

The DB Maint is different from the DB Monitor. The DB Monitor utility allows you to view current 
connections, back up and restore, and view backup history. The DB Maint utility allows you to 
perform maintenance and attempt to repair a corrupted database.   



DB Maintenance Utility        

Details:  
  

Note: This can only be run at the computer where the database is located.  
  

When should it be run?  

• Run it any time that the program performs oddly. If you perform a routine task but get 
unusual results you may have database corruption.  

• We recommend that you also run the database maintenance once per month regardless of 
program performance.  

  

Why should it be run? 
Run this utility to remove database corruption. A database can become corrupt a number of 
ways.  
  

One way the database can become corrupt is through an electrical interruption. We recommend 
that any workstation running the software be connected to a UPS (Uninterrupted Power Supply) 
An inexpensive UPS will give you enough time to close programs and shut down the computer 
properly after a power failure.  
  

Another cause of database corruption is when someone who is running a Gradience program or 
Gradience TimeStation that has been minimized, turns off the computer without first closing the 
program or the TimeStation.  
  

How is it run? 
1. Click on their Windows Start button.  
2. Click Programs.  
3. Click gradience. 
4. Click Maintenance and select DB Maintenance.  
5. Click the Start button that appears on the DB maintenance screen. This should remove 

the corruption from the database.  
6. Close the DB maintenance utility when it is finished and try to open gradience again.  

  
If you have run this utility to resolve a performance issue but the issue persists you have 
two options: 
  

Option One:  
Restore from a recent backup that was made prior to the issue that is now occurring. You will lose 
any data that had been entered since the time that the backup was made.  
Option Two:  
Do a backup and attach the backup to an e-mail and send it to Technical Support. Technical 
Support will “attempt” to remove the suspected database corruption that may be the cause of 
your underlying issue. Technical Support will return a clean backup to you that you can then 
restore into your database.  
  
Note: Although Tech Support clears out corruption in nearly every case, there is no guarantee 
that they will be successful. Be sure to let Tech Support know what the name and the “full” multi-
digit version number of your program.  

  
To find the “full” version number from within he program click on Help (next to Reports) and 
then, click on About 



Database Repair 

If you can’t open the Gradience program, we recommend running the DB Maint utility. It will 
attempt to repair a corrupted database. If the utility does not repair the database, please save 
screen shots of the error messages and contact Tech Support.  
  

We recommend that you make a backup of your database and send a copy of the backup to Tech 
Support via e-mail. Tech Support may be able to repair it. 
If tech Support is able to repair it, they will e-mail it back to you. You can then, restore it into your 
database. 
If Tech Support is NOT able to repair it, you will be advised to restore the most recent backup that 
was made before the problem occurred.  
  
   



DB Maint Features 

The DB Maint utility has the following features: 
Features Description 
Start Begins the maintenance or repair. 
Cancel Stops the maintenance or repair process.  
Print Prints the error message(s). The Print button will not appear unless there are errors. 
Copy Copies the error message(s) to the clipboard. This will allow you to paste it into an e-mail. The Copy 

button will not appear unless there are errors.  
Close Exits the DB Maint utility. 
   
Note: The DB Maint utility will attempt to repair the database that the hrware.ini file points to. (Go 
to Start > Run, and enter: hrware.ini. Locate [HRWARE] in brackets and see the Server name 
and Path for the directory of the Gradience database.) 



Custom Reports 

From any report feature (and after selecting filters and options such as Date ranges, Location and 
Department groupings, etc.), you can begin the process of creating a custom report. Custom 
Reports are a function of the FastReport™ engine built into Gradience. The purpose of this 
tutorial is to take you through the process for creating a custom report, editing some basic 
information inside FastReport, then showing you the outcome. For a full tutorial on working with 
FastReport, please see the FastReport documentation. 

Custom Reports give the user the option to present data from the original (template) report in new 
and exciting ways. How it works: The “default” Gradience report (called a “template” inside the 
application) is used as a base for the new custom report. The user always can start a new report 
from scratch, but it is usually easier to create a new report by modifying a copy of the original 
template. 

To create a custom report based on an existing report, you would click the Save As button and 
select a new name for the report. You then would proceed to edit the new “copy” of the report. To 
edit an existing report, select the report and click the Edit button. If you attempt to edit the 
“Default” report, a new name will be assigned automatically. 

To create a custom report, follow these steps: 

1. For this example, we will use the original Attendance Detail report as a template to create 
a new (custom) version of the report. Start by navigating to Reports > Attendance Detail.  

2.  Locate and click the Custom Report icon near the top right of the page.  
3. A new window titled Custom Reports – Attendance Detail will appear (shown below). As 

you can see, the current report name (in grayed-out text) is Attendance Detail Template.  

 



4. A Custom Sort can be selected by using the drop-down selection in the Custom Sort Fields 
section. Custom Sort Fields work by allowing you to select a field that will be used to sort 
the records on your custom report. Some built-in examples include LastName and 
EmployeeID, and ReportDefault appears as the default selection when you create your 
first custom report (you probably will want to change the default selection). Click Edit first, 
then click the (+) button to the right of the drop-down to edit a Custom Sort field or create a 
new one. 

5. A Custom Filter can be selected by using the drop-down selection in the custom filter 
section. Because you already have activated editing for items in this window, you can go 
ahead and click the (+) button to the right of the drop-down to edit Custom Filters or create 
new ones. 

6. By clicking the View Data button, you can see the results of any changes made to the sorts 
or filters. This can be very helpful when creating your own custom reports because you will 
be able to “preview” your report before you actually begin editing it in FastReport. 

 

7. After previewing your data, click Close in the viewer window to return to the Custom 
Reports window. 

8. If the report you wish to customize is not highlighted in the ReportName section, select the 
desired report now. 

9. Clicking New or Edit will bring you into the FastReport custom report designer. While in the 
designer, you will have the option to save the report as another name or save it to an 
external FastReport 3 (.fr3) file. You also will have the option to open a previously created 
FastReport file and save it in your database. See Help/Help Contents while in the designer 
for more information. 



 

10. Once you are finished editing your custom report in the designer, click File > Save, Save 
As or Exit to close the report to return to Gradience. 

Note: Tech Support does not offer training on Custom Reports. However, we can e-mail you a 
tutorial on Custom Reports free-of charge. To request a copy go to www.gradiencesupport.com 
and click on Ask a Question.  



Importing       

You may import only the fields on the Field Layout There are two different file formats that you 
may import from:  

• Tab Delimited (recommended)  
• Fixed Length 

  
For a Tab Delimited format, you may use any program that allows you to save as Tab Delimited. 
Excel and Access are two that will allow this. Tab Delimited is the recommended format.  
  
Note: You cannot import directly from an Excel file (.xls extension). Once you have finished 
formatting your data in the Excel file, you will need to save as type: Text (Tab Delimited). When 
entering your information into a spreadsheet such as Excel, you will need to follow the order of 
the field names according to the Field Layout page.  
  

For example, the columns should have SSN first, then Last Name, First Name, etc. Also, you will 
need to leave a blank column for any fields that you will leave blank. For example, following the 
format on the Field Layout page, we create a Tab Delimited file with the fields: SSN, Last Name, 
First Name, [blank column for Middle Initial field], Location, Department, Date of Hire, Full/Part 
Time, [blank column for Title field], [blank column for Employee Code field] and Active Status. 
All of the fields in bold are required, which means that these columns may not be blank. We 
would still need to have a blank column for MI, Title and Employee Code in the order of the fields.  
  
For a Fixed Length format, you may use the DOS Editor or any other editor that shows you the 
field length. The lengths of each field must correspond to the Length column under the Field 
Layout page. We recommend using the Tab Delimited format.  
  

Preparing the software for Import 
You must create/setup your Locations and Departments in the gradience program before 
importing. In other words, you must go to Settings > Locations/Departments from within the 
gradience program and enter your locations and department names before importing your data. 
Please refer to the manual for instructions on creating your Locations and Departments. 
  

Import Field Layout 
  
The following is the field layout for importing text files into gradience. Fields shown in bold type 
are required and all import text files must include them. The alphabetical arrangement as 
indicated by the letters on the left indicates the columns under which the information would fall 
within an Excel spreadsheet.  
  

You MUST have a column for each type of information (both “required” & “Not-required” data) 
shown below. Only the items in BOLD below are required. The items not in BOLD below are not 
required fields but the columns which would contain the non-required information MUST exist 
even if they are blank. The data may not be required but the column that would contain such data 
is.  
  

For example:  
If no Social Security Number is available, column A is still required but may remain blank. The 
Last Name is required and MUST appear in column B.  
  

Field Layout Requirements: 
Social Security Number 11 123-45-6789 
Last Name 20 up to 20 characters 



First Name 
20 up to 20 characters 

Middle Name 20 up to 20 characters 
Location 50 up to 50 characters 
Department 50 up to 50 characters 
Date of Hire 10 MM/DD/YYYY (slashes required) 
Full/Part Time 9 Full-Time or Part-Time (only) 
Title 30 up to 30 characters or numbers 
Employee Code 14 up to 14 characters or numbers 
Active Status 10 Active, Inactive, Terminated 

If you have Confidential Employee Record installed, your text file can also include the 
following fields:  

  

Date of Birth 10 MM/DD/YYYY (slashes required) 
Address 1 30 up to 30 characters or numbers 

Address 2 
30 up to 30 characters or numbers 

Home Phone 30 800-123-4657 (dashes required) 
City 30 up to 30 characters or numbers 
State (2 character) 2 2 characters, i.e., FL 
ZIP Code 15 33325-1234 (-1234 can be omitted) 
Salutation 5 Mr., Mrs., Ms. or Dr. (only) 
Employee Security Level 16 up to 16 characters or numbers 
Security Clearance Date 10 MM/DD/YYYY (slashes required) 
Race 25 Must match a valid race on detail tab. 

EEO Category 25 Must match a valid category on the detail tab. 

Sex M/F 1 M or F only 

Driver's License Number 15 up to 15 characters or numbers 

I-9 Renewal Date 10 MM/DD/YYYY (slashes required) 

Veteran Status 25 Disabled, Vietnam Era, Other Veteran 

Office Phone & Ext. 30 800-123-4567 Ext. 123 

Fax 30 800-123-4567 

Email Address 30 up to 30 characters or numbers 

Address Effective Date 10 MM/DD/YYYY (slashes required) 

  



Exporting       

The export feature is used to transfer basic employee information into a text file that you can 
open in any word processor or spreadsheet application. Only the basic information (see Field 
Layout) will be exported.  
To export your information, follow these steps: 

1. Click File > Export. 
2. Select Tab Limited or Fixed Length for the Export File Type. 
3. Enter a path and file name or keep the default name. 
4. Click Export.  

Your export file will be created as the file designated in the file block. You may rename the file, 
but we recommend keeping the file extension of .txt. After exporting, you may open the file from 
within any other spreadsheet or word processor program.  
   
NOTE: Only the information in the Field Layout will be available for export.  
   

   



Importing and Exporting Data 

The import function allows you to add new data from a text file into the Gradience program. 
Conversely, the export function allows you to export data from the Gradience program. 
   

The software you export your data from must be able to export the required information to a Tab 
delimited or fixed-length text file. See the required import fields. Please note that we cannot 
provide support for other software program(s). Please contact the software vendor or 
manufacturer for more information on how to export data from your other software. 
   

   



Import Features       

Feature Description 
Load 
File 

Loads the selected file into the data window. 

Test  This tab will not highlight until a file is loaded. This checks for blank records and ensures that the 
department and location names that are being imported are already in the database.  

Import This tab imports the file into the database.  
Help This brings up the Help file pertaining to Importing. 
Close This closes the Import screen and takes you back to the main screen. 

 
Feature Description 
Import File  This allows you to enter the path or navigate to the file you will be importing.  
File Type  This allows you to select the file type.  

a.   Tab Delimited – We recommend exporting or importing as this type of file.  

b.   Fixed Length – Gradience may export or import fields with a fixed length.  
Skip First 
Line  

This will take out the first row, in case you have headers. 

Check 
Duplicates  

This allows you to check for duplicates against the import file and the files already in the database. 

   



Export TimeClock Data       

The TimeClock Export feature allows you to export the following data: 
     Last 

Name 
     Location 

     First 
Name 

     Department 

     Middle 
Name 

     Punch Hours 

     SSN      Punch Changes 
     Date of 

Birth 
   

Feature Description 
Export 
Type 

Single File – Exports Employee Data and Hours Worked to a single file. If Export Punch Changes is 
selected, it will export to a separate file.  
Relational File – Exports Employee Data and Hours Worked to two separate files. If Export Punch 
Changes is selected, it will export to another separate file.  

Export This allows you to export the data. 
Select 
Employee 
to Export  

This allows you to select specific employees, locations and/or departments to export. 

Hire Range 
Filter  

This allows you to filter on a specific hire date range.  

Job Status 
Filter  

This allows you to filter on full- and part-time. 

Employee 
Status 
Filter  

This allows you to filter on Active, Inactive or Terminated employees.  

Select 
Employee 
Data Fields 
to Export 

Available Fields – This is the list of fields to choose from. 
Fields to Export (In Export Order) – This is the chosen field. 

Export 
TimeClock 
Data 

Export Hours Worked for Period – This allows you to select a date range for timecard data for the 
selected employee(s). 
Export Punch Changes – This allows you to export punch changes. 

   

To export data, follow these steps: 
1. From the File menu, select Export TimeClock Data. 
2. Select the export type: Single File or Relational. 
3. Expand the tree, if necessary, and select the employees to export. 
4. Select the data fields to export by either double-clicking on the file or selecting the file and 

clicking on the arrow pointing to the right. 
5. If needed, select the Export Hours Worked option with a date range. 
6. If Export Hours Worked is selected, you can select to Export Punch Changes option. 
7. Click Export.  



Getting Help 

There are several ways to get help throughout the program.  
   



Sample Database  

A sample company (called a tutorial database) is provided so you can view the different screens 
with sample data already filled in. It is recommended that you use the program with the tutorial 
database to get a feel for the program without having to worry about altering live data. When you 
are in the tutorial database, no changes are made to your live database. To open the tutorial 
database, select Start, Programs, Gradience, Data. 

The Help Menu 

From the Help menu, select Contents. A listing of help topics is displayed. Select the Book that 
interests you (using a double-click), and then double-click the topic you wish to display.  
   



The F1 Key 

Pressing the F1 key is another way to obtain help within the program. From most areas of the 
program, pressing  F1 will display the topic associated for that screen.  
   



Searching for Help 

You can search for Help two ways using the Help File.  
Method 1 – From the  Help menu, select  Search for Help on. The Help Topics Index will 
appear. Select the Topic that interests you.  
   
Method 2 – From the Help menu, select  Contents. Click the  Find Tab. If you have not used this 
feature before, the Find Setup Wizard will walk you through setting up the search index. Once the 
search index has been created, type in the Keywords you would like to search for, and the 
results will be displayed.  
   

A list of typical errors or messages that were known at the time of publication is in Appendix B – 
Troubleshooting.  
   

For more complete information, please refer to one of the following: 

• Read me. txt file in the C:\Program Files\ Gradience\Common program directory.  
• Help File in C:\Program Files\Gradience\Common or accessible from the Start Menu.  
• Internet Site www.gradiencesupport.com 

   
   



Before Contacting Technical Support  

Please follow these guidelines before contacting Technical Support:  

• Remember, Gradience does not support setting up networks or computer configurations.  
• If you are having problems with your computer, try rebooting to see whether that corrects 

the issue. 
• If you are getting an error message, an access violation or encounter the software 

behaving in a manner that is unusual, go to the computer where the database is located 
and run the Database Maintenance. 
 
From the desktop click on Start > Programs (or All Programs) > Gradience > 
Maintenance > DB Maintenance. When the DB Maintenance window opens click on the 
Start button within that window. When it is finished, see if the issue that you are having 
with the software persists. Often this utility will resolve the issue. 

• If the issue is an error message and the Database Maintenance did not resolve it, please 
write down the whole message or take a screen print of it by clicking on the Print Screen 
key in the upper-right of your keyboard and then, paste it into MS Word or Wordpad or 
Notepad and save it to send in an e-mail to Tech Support later.  

• When communicating with Tech Support be ready to first indicate the “full” name of the 
software and the “full”, multi-digit version number of the program. You can find this by 
opening the program and clicking on Help and then clicking on About. A pop-up window 
will open that will indicate the “full”, multi-digit version number of the program. Sometimes 
the answer depends on this version number.  

• Indicate the steps that you took that lead-up to the problem that you have encountered.  
• Indicate whether you were able to run the Database Maintenance or not and whether it 

had any impact.  

  



Contacting Technical Support       

• Version 10 was introduced in November of 2007. We support the “current” version (10) 
and the “previous” version (9). A “Pro” license allows you to install it at one site and get 
support for that site. An “Enterprise” license allows you to install it at multiple sites and get 
support for each of those sites.  

• FREE phone support during the 30-day DEMO  
• FREE phone support for the first 30 days after you purchase the software  
• Technical support for by e-mail is ALWAYS FREE. Just go to www.gradiencesupport.com 

and click on:  
o Get Fast Answers to do a keyword search.  
o Ask a Question to request help from a Technical Support representative.  

Long-Term Phone Support 888-925-7740 (8:30 AM to 6:00 PM Eastern Time Monday 
through Friday except Holidays) 

• With a Maintenance Plan: One full year of phone support (not training) for technical 
issues and FREE software upgrades. For details call 800-999-9111 or 888-925-7740.  

• Without a Maintenance Plan: You will be charged $29.99 for each call to Tech Support.  
Assistance with understanding how to use the software 

• Professional Services: Get up to two hours of training and help setting up the software. 
For details call 800-999-9111 or 888-925-7740.  



Troubleshooting 

Here are the most common problems you may experience when using Gradience.   

• Unable to connect to Interbase Server 
• Getting SQL Parse Error: EOF in String Detected message when logging in 
• Unable to install on a Win NT or 2000 system 
• Exceeded the authorized user count 
• Moving database from one location to another 
• Installing Gradience files to another drive other than c:\ 
• Installing Update from one location 



Frequently Asked Questions       

Q: Can I map the drive to the database as I did in Version 6 of your other software? 

A: No. There is no mapping involved. If the database is on a network drive, the Client Workstation 
communicates to the Server through TCP/IP. When you enter the path for the Server, it must be 
“as seen” from the Server. (For example, if the Server Name is Server 1 and the Gradience 
Database Path on the Server is: 
C:\Program Files\Gradience\Data\HRWARE.GDB 

then this is what will be entered (EXACTLY) when installing to a Client Workstation.  
   

Q: What do I need to know before installing to a network drive? 
A: Installing the database to the network and the program files to a Client Workstation(s) is a two-
step process. You’ll need to install onto the Server (must be physically at the Server), and then to 
the Client Workstation(s). Keep in mind: 

1. No drive mapping is involved.  
2. TCP/IP must be installed at the Client and Server if database is on the Server.  
3. When installing to the Server, you will be prompted to write down or print out the Server 

name and database path. Make sure you write these down EXACTLY as shown. You 
cannot install to the Server from the Client. When installing to the Client and when 
prompted for the Server name and database path, enter these EXACTLY as shown from 
the Server install. NO DRIVE MAPPING IS NEEDED. 

4. After installing, check to make sure you can run the program from the Server. If you’re 
having problems connecting to the database, check to make sure you have System – Full 
Control on the Gradience folder. 

   

Q: What is the difference between the TimeStation and the TimeClock Admin? 
A: The TimeStation is where your employees clock in/out and usually is installed on a 
computer(s) in a convenient location accessible to employees. This computer also can have a 
swipe card reader attached to make clocking in/out easier. The TimeClock Admin is for 
managers and supervisors. This is where administrative work is done, such as setting up 
TimeClock access, and editing and printing timecards. 
   

Q: What kind of install (Standalone, Server, or Client) should I perform? 
A: We recommend putting the database on the Server and the program on a Client Workstation. 
A Server has a less likely chance of locking up or crashing, and allows the database to remain 
stable. A Client-Server installation requires 1) installing to a Server, and then 2) installing the 
Client(s).  
   

Q: There isn’t room on the C:\ drive on the Server. Can I install the database files and 
Firebird (Db Engine) files to another drive other than C:\? 

A: Yes. Follow these steps: 
1. When installing Gradience to the Server, install the program and database files first. Select 

Custom after the Setup type and click Next. This will give you the choice of where to install 
the program and database files.  

2. After you click on Finish, it will prompt you to install Firebird, the database engine. Click 
Cancel to quit the installation process at this point. 

3. Using Windows Explorer, navigate on the Gradience CD to the BIN\Firebird folder and 
run the  install file. This will allow you to install Firebird to a physical drive.  

   
NOTE: The Gradience files need to reside on a physical drive, not a mapped drive. 

   



Unable to Connect to Interbase Server             

Users Affected 

Gradience Attendance 

Gradience Records 
Gradience TimeClock 
   

Issue 

When launching one of the programs above, the following message may be encountered: 
   

"This program was unable to connect to your Firebird/Interbase Server. This likely is due to the 
fact that the default Interbase User Account has been changed. Please provide a User Name and 
Password with Administrative Privileges to Interbase." 
   

Description 

Users may encounter this issue for one of the following reasons. 
If running from a Server: 

1. If you're using an NT server and trying to install the database files to a drive other than C:\, 
permissions to the database folder may be incorrect. 

2. If running from a Standalone Computer: 
3. Interbase Guardian may be shut down 
4. If running from a Client Workstation: 
5. Incorrect Server Name and/or Database Path 
6. Client needs to have TCP/IP installed 
7. Server may be down 
8. Attempting to launch remotely. Remoting tool cannot resolve "Localhost" or "Name of 

Server." Change these to the Server's IP address in the hrware.ini file. 
Possible Resolution 

1. If running Gradience from a Server and encountering the above problem, try each of these 
solutions: 

2. Check your permissions for the Database folder. Full Control access must be given to 
System for the database folder. You may add to the Permissions by going through 
Windows NT Explorer and going to Properties by right-clicking the database folder. 

3. Check to make sure Interbase Guardian (or Interbase Manager) is running. 
4. On a Win 95/98 system, there will be an icon in the system tray (next to the clock). The 

icon graphic appears as a gray tower with a green flag. When you put your mouse over the 
icon, it will read, "Interbase Guardian". This icon will not appear on a Win NT/2000 system. 
You may check to see whether it is running on a Win 95/98/NT/2000 system by clicking on 
Start, Settings, Control Panel and clicking on the Interbase Manager. If it is not running, 
click on Start (from within the Interbase Manager), then try to open the Gradience 
application again. 

5. If encountering the message when running from a Client Workstation, try this: 
6. Check the Server Name and Database Path by going to the Server, opening the 

Gradience application and clicking on Help, System Information and printing out this 
information from the TechSupport Tab. (If you don't have the TechSupport Tab, then you 
have an earlier version of Gradience and will need to do a screen shot of the System 
Information screen and Current Users screen and print them out.)  

7. Once you have the Server information, go to the Client Workstation you cannot connect to 
the Server with. From the Workstation, click on Start, Run, and enter: HRWARE.INI. Verify 
that the Server Name and Database path are the same. 
   



NOTE: The printout of the Server Name and Database path you were asked to print or 
write down when installing the Server side must be exactly the same when entering this 
information on the Client Workstation(s)!  
   

8. The Client needs to have TCP/IP installed. 
9. This is done through the Network Neighborhood Properties. Please see your Network 

Administrator if you need more assistance in setting this up. 
   

If everything is the same on the Client as it is on the Server and you're still unable to 
connect, then try this: 
   

If your Server has a static IP Address, try entering this for the Server name when installing 
to the Client Workstation. 
   

10. If running from a Client Workstation and you went through the steps above and it didn't fix 
the problem, check with your MIS or Network Administrator regarding the status of the 
Server. 

   



Getting SQL Parse Error: EOF in String Detected                   

Issue: Getting an error message when logging in. Receive the following error message when 
logging in: SQL Parse Error: EOF in String Detected 
   

Description: This is caused when pressing the comma key ( , ) and Enter key at the same time. 
   

Possible Resolution(s):  

Avoid pressing the comma and Enter key at the same time.  



Unable to install on a Windows 2000 system             

Issue: Doesn’t finish installation. 
   

Description: This usually happens if you do not have full administrator rights on the Windows 
2000 computer. 
   

Possible Resolution(s): 

Make sure you have full administrator rights before installing.  



Exceeded the Authorized User Count             

Issue: 
You have exceeded the authorized user count. Your product license allows up to [number of 
licensed users] simultaneous users. There are # connections at this time. 
   

The # connections is a number greater than one that changes each time you close and reenter 
the program. 
   

Description: 

Users may experience this problem when closing the program by clicking Exit under the File 
menu. Users who exit the program by clicking the close window icon in the top right corner will 
not experience the problem, but we still recommend downloading and installing the latest update.  
   

Possible Resolution: 
Download and install the latest Gradience program from our Updates area on our Web site at: 
www.gradiencesupport.com. 
   

Please follow the installation instructions. After downloading and installing the update, follow the 
steps below to clear the connections. 

1. Close Gradience and any other Gradience Programs that are open. 
2. Open DB Monitor and log in, if it is not already running. The DB Monitor resides on the 

computer where the Gradience database is installed. 
3. Click the Connections button. 
4. Click the Refresh button to verify all connections are "N" (not active).  
5. If all connections are "N", then Click the Clear Inactive Connectionsbutton. This will reset 

the connections.  
6. If you wish to close the DB Monitor (not recommended if you have automatic database 

backups scheduled), right-click on the icon Gradience Database Monitor in the system 
tray area; select Shutdown Database Monitor, and click OK to close DB Monitor. 

7. Otherwise, click the Hide button. 



Moving Database from One Location to Another 

Steps to follow:  
1. Install the software on the new server. (See Installing Gradience).  

 
Note: In the event that you have had your CD for a number of months you may not be 
running the latest “edition” of the version you own. We recommend that you download the 
latest ‘edition” of your version from our Tech Support web site. 
 
Go to www.gradiencesupport.com and click on Download latest versions.  
 

2. Download the appropriate program, saving it to the desktop of the server.  
3. Install it on the server doing a Server installation and then pick Custom or Express. This 

will create a new “blank” database on the new server. Take note of the location of the 
database, return to your client workstation(s)  

4. From the desktop of each client workstation click Start > Run. Enter hrware.ini into the 
field and click OK. A NotePad window will open.  

5. At the top you will see the following …  
[HRWARE]  
SERVER= (the name of the computer where the database had been)  
PATH= the path to the database)  
The second and third lines may be reversed on your ini file.  

6. Edit the SERVER name and if necessary, edit the PATH line, Save and close. This will 
“point the program on this computer to the new database location. There is no data there 
yet so the program will not open yet.  

7. Go to the computer where the database had been. Open Windows Explorer (not internet 
Explorer).  

8. Navigate to the database (Hrware.gdb), “Copy” it, Paste it into a shared folder on the 
network and close Windows Explorer.  

9. Go to the new server and navigate to the shared folder and “Copy” the database 
(hrware.gdb).  

10. Navigate to the new, “blank” database (hrware.gdb). Paste the copy of the original 
database into the same folder. This will overwrite the new, “blank” database with a copy of 
your production database.  

   



Installing Gradience Files to Another Drive Other Than C:\ 

Issue: 

Installing Gradience files to another drive other than the C:\ drive. 
   

Description: 
Sometimes installing to the C:\ drive is not feasible. It may not have much space left or it’s not 
meant for database files.  
   

Possible Resolution: 
When installing Gradience, there are three sets of files that get installed: Program Files, 
Database Files and Database Engine Files (Interbase). When choosing Custom Install, you may 
select the location for the Program and Database Files that get installed at the same time. 
Interbase automatically will install to the c:\ drive after you click on the first Finish button. If this is 
OK, then you only need to follow Step 1 below and click on Finish. Otherwise, if you also want to 
install Interbase to another drive, then follow all of the below steps: 

1. Run the installation of the selected Gradience program (such as Gradience Attendance , 
Records or TimeClock. When going through the installation process, choose Custom for 
the Installation Type. For the next two screens (Program Files and Database Files 
Location), click Browse to choose where to install them.  

2. Stop at the point where it says FINISH. Do not click on it. Leave the install window open at 
this screen. Open Windows Explorer and go to the Windows Temp directory. 

3. From the Windows Temp directory, find (or do a search for) IBWin32setup.exe. 
4. Double-click on this file to start the installation process. This will install the database 

engine files (Interbase) and give you the ability to install these files to a drive other than 
C:\.  



Install Update from One Location  

Issue: 
When a new update is released, you must install at each client workstation(s) and at the 
database server. These instructions will show you how to set up the Gradience folders to install 
only the new update once from one central location.  
   

Description: 

Setting up one shared directory for the program files will make updates quicker and easier.  
   

Possible Resolution: 
These instructions will explain how to set up the Gradience program files in one shared location 
to make updating easier: 
   

1. Copy the Gradience installation file(s) to a shared directory. The Server and all 
workstations that will have (or already have) Gradience installed should have access to 
this shared directory on the network. If you downloaded the Gradience update from our 
Web site (www.gradiencesupport.com), then you will have only one file. If you have a 
Gradience CD, then you will need to copy the appropriate Gradience program keeping all 
of its folders intact. For example, while navigating the Gradience CD through Windows 
Explorer, under the BIN folder, you would copy the Atcon70 folder to the shared directory.  

2. From the Server (or computer where the database resides), navigate to the shared 
directory, and run the Server installation (even if the Gradience program already is 
installed on the Server) by following these steps: 

1. At the Setup Type, select  Server. Click  Next. 
2. At the Installation Type, select  Custom. Click Next. 
3. At Select Components, leave the defaults. Click Next. 
4. At the Program Files Location, click Browse and navigate to the Shared directory. 

Add \Gradience to the end of the Path. 
5. At the HRWare Database Files  Location, click Next. 
6. Write down or print the Server Name and path. These will be needed for the Client 

installs. Click Close, then Next. This will install the Server files. 
7. If the Interbase install starts, click Next to install it; otherwise, go to Step  H. 
8. Go to Client Workstation. 

3. From the Client Workstation, navigate to the shared directory, and run the Gradience 
installation (even if the Gradience program already is installed on the Workstation) by 
following these steps:  

1. At the Setup  Type, select  Client. Click  Next. 
2. At the Installation  Type, select  Custom. Click  Next.  
3. At Select  Components, leave the defaults. Click  Next. 
4. At the ProgramFiles Location, click Browse, and navigate to the \Gradience 

shared directory created during the Server install. Click Next. 
5. At the Database Server Information screen, enter the Server name and database 

path exactly as shown from the Server install.  
6. Click Next. This will install the program files. 
7. Follow the above steps for any other Client Workstations that will have Gradience 

installed. 
   
When the above steps are completed once, then when you need to install an update, only 
steps 1 and 2 (a-g) need to be completed. All users must exit the Gradience program(s) before 
updating. All of the shortcuts on the Client Workstations will be pointed to the shared directory 
that will be updated when the Server install is completed. 
   



USB Fingerprint (BIO) Reader Setup Guide 

1. From within the management portion click on Settings > Global Preferences > 
Fingerprint Reader.  

2. Then click on Edit and check Enable Fingerprint Reader and then click Save. You will 
have to close out of the program and reopen it for that change to take effect.  

3. After opening the program, enter the management portion.  
4. Select the first employee that needs to have their fingerprint registered and then click on 

Time Clock Access.  
5. On the right side of the screen under the title Fingerprint click on Add. A new screen will 

appear giving you the steps to follow for registering fingerprints.  
  
   

  



Pre-setup Requirements 

The following should be completed before setting up the USB Fingerprint Reader:  

• TimeClock Application installed (Gradience 10.0.712.13 and above) 
• Device Driver for the USB Fingerprint Reader installed 
• USB Fingerprint Reader connected 



User Access vs. Employee Access 

User Access – is given to Supervisors and Managers and to anyone else who will need access to 
set up or maintain the program. User Access is set up through the User Security feature.  
Employee Access – is given to those employees who will be clocking in and out. Employee 
Access is set up through the TimeClock Access feature. 



Setting up User Access for Use with the Fingerprint Reader 

1. From within the TimeClock Administration, go to Settings, then User Security.  
2. Either select a user from the list or create a new user. 
3. Under the Fingerprint heading, click on the Add button and follow the on-screen 

instructions. 
4. Click the Save button when completed. 



Logging into My TimeClock with the Fingerprint Reader 

1. From the TimeStation screen, click on the My TimeClock button or press F9.  
2. At the login screen, you may log in by fingerprint any time the “Fingerprint Scanner 

Ready…” message is displaying.  



Setting up Employee Access for Use with the Fingerprint Reader 

1. From within the TimeClock Administration, go to TimeClock Access. 
2. Select an employee to edit. 
3. Under the Fingerprint heading, click on the Add button and follow the on-screen 

instructions. 
4. Under the TimeClock Access heading, place a check mark in the Enable Employee 

TimeClock Access checkbox. If this is unchecked, the selected employee will not have 
access to clock in/out.  

5. Click the Save button when completed. 



Clocking in/out Using the Fingerprint Reader 

A learning curve is not involved in clocking in and out with the Fingerprint Reader.  
1. Connect the USB Fingerprint Reader to the same computer where the TimeStation is 

running. 
2. Employees clock in/out by placing a finger on the Fingerprint Reader at any time when the 

TimeStation is running.  



Logging into the TimeClock Administration Using the 
Fingerprint Reader 

1. Close out and launch TimeClock Administration to get to the login screen. 
2. At the login screen, you may log in by fingerprint any time the “Fingerprint Scanner 

Ready…” message is displaying. The Fingerprint Scanner will become inactive after 90 
seconds. 



Maintenance 

Using a nonscratch cloth, clean the lens of the Fingerprint Reader as needed.  
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The above marks in gray designate minutes with the decimal equivalent below them. Semi-gray 
marks designate minutes that are equally divisible by 60.  
   

The formula for getting the decimal number is minutes divided by 60.  
   

Gradience TimeClock automatically converts the time entry minutes to decimals. For example, if 
Joe had worked 8 hours and 30 minutes, Gradience TimeClock would show this as 8.5 hours. 
This makes it easier for payroll purposes. 
   

   
   



  



Magnetic Stripe Card Specifications       

This information is for if you are going to use a card reader:  

• Keyboard Wedge – The reader may be a magnetic stripe card or barcode reader. We have 
tested with a keyboard wedge, which the keyboard connects into the reader and then to 
the computer. 

• Formats: ISO 7811, AAMVA and CA DMV. 
• Cards must be pre-encoded (on one track only) with up to 24 alphanumeric characters on 

track 1, 2 or 3, with a single carriage return at the end. 
• If you have a technical question, please contact Tech Support at (888) 925-7740. 

  



Standard Time vs. Military Time 

The following chart is for reference. 
Standard Time  Military Time 

12 pm  1200 hrs 
12:30 pm 1230 hrs 
1 pm  1300 hrs 
2 pm  1400 hrs 
3 pm  1500 hrs 
4 pm  1600 hrs 

5 pm  1700 hrs 
6 pm  1800 hrs 
7 pm  1900 hrs 
8 pm  2000 hrs 
9 pm  2100 hrs 
10 pm  2200 hrs 
11 pm  2300 hrs 
12 am  2400 hrs 
1 am  0100 hrs 
2 am  0200 hrs 
3 am  0300 hrs 
4 am  0400 hrs 
5 am  0500 hrs 
6 am  0600 hrs 

7 am  0700 hrs 
8 am  0800 hrs 
9 am  0900 hrs 
10 am  1000 hrs 
11 am  1100 hrs 
   
   



ET215 Terminal Quick Start 

Overview 

This is a QUICK START document for use with the TimeClock Remote Ethernet Terminal. It will 
help the first-time user get a terminal installed and communicating rapidly. It is strongly 
recommended that this documentation is reviewed BEFORE installation of the terminal is 
attempted. 
   

It is assumed that the user has a host computer with the TCP/IP network protocol installed, and 
the computer is connected to the Ethernet network. It is also assumed that the installer is familiar 
with network fundamentals such as IP address and port number. The Gradience TimeClock 
Remote program is required to remotely configure and test the terminal over the network.  
   

TimeClock Remote Configuration 

The terminal must be configured with a valid IP address BEFORE it can be installed on the 
network. Initially this process is accomplished using the keypad and display. Once it is configured 
properly and installed on the network, it can be reconfigured over the network using the 
Gradience TimeClock Remote program. 

1. Attach the power adapter to the terminal and plug the adapter into a power receptacle. 
2. The terminal should “beep” three (3) times and then display the “Offline” message. 
3. Hold down the “S1” and “S2” keys and then press the “IN” key to enter the configuration 

mode. A menu will be displayed; press the “2” key to modify the configuration parameters. 
4. The default IP address will be displayed. In most cases the default IP address 

(192.168.168.50) will have to be changed. Use the keypad to modify the IP address value 
and press the “Enter” key. 

5. The default network mask will be displayed next. Change this if you have a network mask 
and press the “Enter” key.  

6. The other setup parameters are presented one at a time on the terminal display. Press 
“Enter” until you get to MODE. Change the Mode parameter to 2. The default values for 
the others should be valid for most applications and can be accepted by pressing the 
“Enter” key.  

7. When all of the setup parameters have been entered, the terminal will return to the 
configuration menu. Press the “Enter” key to exit the configuration mode. The “Offline” 
message will be displayed. 

8. At this point, the terminal can be powered down and is ready for installation. 
   

Installation 

   

Once the TimeClock Remote has been configured, it can be installed on the network. 
1. Connect the terminal (RJ-45) to a 10/100BaseT Ethernet hub (or switch) with a standard 

Ethernet cable.  
2. When power is applied, one of the network status LED indicators should light. 
3. Start the TimeClock Remote program on the host Windows PC computer and login by 

going to File > User Login. 
4. Click File > New Terminal to create a new terminal connection. The Terminal Name is 

what will display under Help > System Information on any Gradience program. Select the 
TimeClock Remote (or the appropriate Terminal Type) and enter the IP address and the 
Port Number (default is 1070). 

5. Select Connect at Startup and press Connect. The TimeClock Remote program will display 
Connected, and the Terminal will respond with the date and time. This indicates the 
Terminal is communicating over the network and is ready to accept commands. 



6. Data can be entered on the TimeClock Remote keypad by pressing the numeric keys and 
then pressing the “Enter” key. The entered message will appear on the Telnet client 
screen.  

7. If the TimeClock Remote is equipped with a card reader (mag stripe) the decoded output 
can be displayed. 

Optional digital I/O functions also can be tested using the RELAY, INPUTS and COUNTER 
commands. 
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